Kuroni and Simple Strings

Kuroni and Simple Strings

题面翻译

给定一个括号序列,求至少删除多少次使得原序列中不存在「好子序列」并输出删除方案,如果本身就没有「好子序列」则输出 0 0 0

「好子序列」的定义是长度为 2 k 2k 2k 1 ∼ k 1\sim k 1k 都为 ( k + 1 ∼ 2 k k+1\sim 2k k+12k 都是 ) 的子序列。删除操作规定每次只能选择原序列中的一个「好子序列」并删除其中的全部元素。

n ≤ 5000 n\leq 5000 n5000

题目描述

Now that Kuroni has reached 10 years old, he is a big boy and doesn’t like arrays of integers as presents anymore. This year he wants a Bracket sequence as a Birthday present. More specifically, he wants a bracket sequence so complex that no matter how hard he tries, he will not be able to remove a simple subsequence!

We say that a string formed by $ n $ characters ‘(’ or ‘)’ is simple if its length $ n $ is even and positive, its first $ \frac{n}{2} $ characters are ‘(’, and its last $ \frac{n}{2} $ characters are ‘)’. For example, the strings () and (()) are simple, while the strings )( and ()() are not simple.

Kuroni will be given a string formed by characters ‘(’ and ‘)’ (the given string is not necessarily simple). An operation consists of choosing a subsequence of the characters of the string that forms a simple string and removing all the characters of this subsequence from the string. Note that this subsequence doesn’t have to be continuous. For example, he can apply the operation to the string ‘)()(()))’, to choose a subsequence of bold characters, as it forms a simple string ‘(())’, delete these bold characters from the string and to get ‘))()’.

Kuroni has to perform the minimum possible number of operations on the string, in such a way that no more operations can be performed on the remaining string. The resulting string does not have to be empty.

Since the given string is too large, Kuroni is unable to figure out how to minimize the number of operations. Can you help him do it instead?

A sequence of characters $ a $ is a subsequence of a string $ b $ if $ a $ can be obtained from $ b $ by deletion of several (possibly, zero or all) characters.

输入格式

The only line of input contains a string $ s $ ( $ 1 \le |s| \le 1000 $ ) formed by characters ‘(’ and ‘)’, where $ |s| $ is the length of $ s $ .

输出格式

In the first line, print an integer $ k $ — the minimum number of operations you have to apply. Then, print $ 2k $ lines describing the operations in the following format:

For each operation, print a line containing an integer $ m $ — the number of characters in the subsequence you will remove.

Then, print a line containing $ m $ integers $ 1 \le a_1 < a_2 < \dots < a_m $ — the indices of the characters you will remove. All integers must be less than or equal to the length of the current string, and the corresponding subsequence must form a simple string.

If there are multiple valid sequences of operations with the smallest $ k $ , you may print any of them.

样例 #1

样例输入 #1

(()((

样例输出 #1

1
2
1 3

样例 #2

样例输入 #2

)(

样例输出 #2

0

样例 #3

样例输入 #3

(()())

样例输出 #3

1
4
1 2 5 6

提示

In the first sample, the string is ‘(()((’. The operation described corresponds to deleting the bolded subsequence. The resulting string is ‘(((’, and no more operations can be performed on it. Another valid answer is choosing indices $ 2 $ and $ 3 $ , which results in the same final string.

In the second sample, it is already impossible to perform any operations.

#include<stdio.h>
#include<string.h>
int main(void)
{
	char s[1001] = { 0 };
	scanf("%s", s );
	int left = -1, right = strlen(s);
	int xuhao[1000][2] = { 0 }; int i = 1,caozuocishu=0;
	while (left<right)
	{
		while (left<right)
		{
			if (s[++left] == '(')
			{
				xuhao[i++][1] = left+1;
				break;
			}
		}
		while (left<right)
		{
			if (s[--right] == ')')
			{
				xuhao[i-1][2] = right +1;
				caozuocishu++;
				break;
			}
		}
	}
	if (caozuocishu)
	{
		printf("1\n%d\n", 2 * caozuocishu);
		for (int i = 1; i <= caozuocishu; i++)
		{
			printf("%d ", xuhao[i][1]);
		}
		for (int i = caozuocishu; i >=1; i--)
		{
			printf("%d ", xuhao[i][2]);
		}
	}
	else
	{
		printf("0");
	}

	return 0;
}

事实上最小次数为1或者0
双指针
逆向思考 最后的状态只能为若干((或若干))或者若个个)和若干(。之前每次取的个数(与)相等。那么上一次就可以一次取光光。1次自然是最小的,

在探索智慧旅游的新纪元中,一个集科技、创新与服务于一体的整体解决方案正悄然改变着我们的旅行方式。智慧旅游,作为智慧城市的重要分支,旨在通过新一代信息技术,如云计算、大数据、物联网等,为游客、旅游企业及政府部门提供无缝对接、高效互动的旅游体验与管理模式。这一方案不仅重新定义了旅游行业的服务标准,更开启了旅游业数字化转型的新篇章。 智慧旅游的核心在于“以人为本”,它不仅仅关注技术的革新,更注重游客体验的提升。从游前的行程规划、信息查询,到游中的智能导航、个性化导览,再到游后的心情分享、服务评价,智慧旅游通过构建“一云多屏”的服务平台,让游客在旅游的全过程中都能享受到便捷、个性化的服务。例如,游客可以通过手机APP轻松定制专属行程,利用智能语音导览深入了解景点背后的故事,甚至通过三维GIS地图实现虚拟漫游,提前感受目的地的魅力。这些创新服务不仅增强了游客的参与感和满意度,也让旅游变得更加智能化、趣味化。 此外,智慧旅游还为旅游企业和政府部门带来了前所未有的管理变革。通过大数据分析,旅游企业能够精准把握市场动态,实现旅游产品的精准营销和个性化推荐,从而提升市场竞争力。而政府部门则能利用智慧旅游平台实现对旅游资源的科学规划和精细管理,提高监管效率和质量。例如,通过实时监控和数据分析,政府可以迅速应对旅游高峰期的客流压力,有效预防景区超载,保障游客安全。同时,智慧旅游还促进了跨行业、跨部门的数据共享与协同合作,为旅游业的可持续发展奠定了坚实基础。总之,智慧旅游以其独特的魅力和无限潜力,正引领着旅游业迈向一个更加智慧、便捷、高效的新时代。
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值