Bogosort

Bogosort

题面翻译

题目大意:

  • 构造一个 a a a 序列
  • 使得 j − a j ≠ i − a i ( i < j ) j-a_j≠i-a_i (i<j) jaj=iai(i<j)

输入输出:

  • t t t 组数据,每组数据一个 n n n 和一个长度为 n n n 的序列 a 1 , a 2 . . . a n a_1,a_2...a_n a1,a2...an
  • 对每一组输入输出一个可行的序列。

数据范围: 1 ≤ t ≤ 100 1\le t\le 100 1t100 1 ≤ n ≤ 100 1\le n\le 100 1n100 1 ≤ a i ≤ 100 1\le a_i\le 100 1ai100

题目描述

You are given an array $ a_1, a_2, \dots , a_n $ . Array is good if for each pair of indexes $ i < j $ the condition $ j - a_j \ne i - a_i $ holds. Can you shuffle this array so that it becomes good? To shuffle an array means to reorder its elements arbitrarily (leaving the initial order is also an option).

For example, if $ a = [1, 1, 3, 5] $ , then shuffled arrays $ [1, 3, 5, 1] $ , $ [3, 5, 1, 1] $ and $ [5, 3, 1, 1] $ are good, but shuffled arrays $ [3, 1, 5, 1] $ , $ [1, 1, 3, 5] $ and $ [1, 1, 5, 3] $ aren’t.

It’s guaranteed that it’s always possible to shuffle an array to meet this condition.

输入格式

The first line contains one integer $ t $ ( $ 1 \le t \le 100 $ ) — the number of test cases.

The first line of each test case contains one integer $ n $ ( $ 1 \le n \le 100 $ ) — the length of array $ a $ .

The second line of each test case contains $ n $ integers $ a_1, a_2, \dots , a_n $ ( $ 1 \le a_i \le 100 $ ).

输出格式

For each test case print the shuffled version of the array $ a $ which is good.

样例 #1

样例输入 #1

3
1
7
4
1 1 3 5
6
3 2 1 5 6 4

样例输出 #1

7
1 5 1 3
2 4 6 1 3 5
int split(int a[], int low, int high)
{
	int part_element = a[low];

	for (;;)
	{
		while (low < high && part_element <= a[high])
			high--;
		if (low >= high) break;
		a[low++] = a[high];

		while (low < high && a[low] <= part_element)
			low++;
		if (low >= high) break;
		a[high--] = a[low];
	}

	a[high] = part_element;
	return high;
}
void sort(int a[], int low, int high)
{
	int middle;
	if (low >= high) return;
	middle = split(a, low, high);
	sort(a, low, middle - 1);
	sort(a, middle + 1, high);
}
#include<stdio.h>
int main(void)
{
	int t;
	scanf("%d", &t);
	while (t--)
	{
		int n;
		scanf("%d", &n);
		int ch[1000] = { 0 };
		for (int i = 0; i < n; i++)
		{
			scanf("%d", &ch[i]);//从小到大排序
		}
		sort(ch, 0,n-1);
		for (int i = n - 1; i > 0; i--)
		{
			printf("%d ", ch[i]);//倒序输出
		}
		printf("%d\n", ch[0]);
	}
	return 0;
}

只要求一组输出,则找特解。排序后倒序输出即可。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值