有根树(数据结构与算法)

学习数据结构与算法的时候学到了树这一章

由此来写篇文章复习一下所学知识

题目位于

http://judge.u-aizu.ac.jp/onlinejudge/description.jsp?id=ALDS1_7_A

Your task is to write a program which reports the following information for each node u of a given rooted tree T:

node ID of u

parent of u

depth of u

node type (root, internal node or leaf)

a list of chidlren of u

If the last edge on the path from the root r of a tree T to a node x is (p, x), then p is the parent of x, and x is a child of p. The root is the only node in T with no parent.

A node with no children is an external node or leaf. A nonleaf node is an internal node

The number of children of a node x in a rooted tree T is called the degree of x.

The length of the path from the root r to a node x is the depth of x in T.

Here, the given tree consists of n nodes and evey node has a unique ID from 0 to n-1.

Input

The first line of the input includes an integer n, the number of nodes of the tree.

In the next n lines, the information of each node u is given in the following format:

id k c1 c2 … ck

where id is the node ID of u, k is the degree of u, c1 … ck are node IDs of 1st, … kth child of u. If the node does not have a child, the k is 0.

Output

Print the information of each node in the following format ordered by IDs:

node id: parent = p, depth = d, type, [c1…ck]

p is ID of its parent. If the node does not have a parent, print -1.

d is depth of the node.

type is a type of nodes represented by a string (root, internal node or leaf). If the root can be considered as a leaf or an internal node, print root.

c1…ck is the list of children as a ordered tree.

Please follow the format presented in a sample output below.

Constraints

1 ≤ n ≤ 100000

Sample Input 1

13
0 3 1 4 10
1 2 2 3
2 0
3 0
4 3 5 6 7
5 0
6 0
7 2 8 9
8 0
9 0
10 2 11 12
11 0
12 0

Sample Output 1

node 0: parent = -1, depth = 0, root, [1, 4, 10]
node 1: parent = 0, depth = 1, internal node, [2, 3]
node 2: parent = 1, depth = 2, leaf, []
node 3: parent = 1, depth = 2, leaf, []
node 4: parent = 0, depth = 1, internal node, [5, 6, 7]
node 5: parent = 4, depth = 2, leaf, []
node 6: parent = 4, depth = 2, leaf, []
node 7: parent = 4, depth = 2, internal node, [8, 9]
node 8: parent = 7, depth = 3, leaf, []
node 9: parent = 7, depth = 3, leaf, []
node 10: parent = 0, depth = 1, internal node, [11, 12]
node 11: parent = 10, depth = 2, leaf, []
node 12: parent = 10, depth = 2, leaf, []

Sample Input 2

4
1 3 3 2 0
0 0
3 0
2 0

Sample Output 2

node 0: parent = 1, depth = 1, leaf, []
node 1: parent = -1, depth = 0, root, [3, 2, 0]
node 2: parent = 1, depth = 1, leaf, []
node 3: parent = 1, depth = 1, leaf, []

请编写一个程序,输出给定有根树T中各节点u的信息,信息内容如下。

->u的节点编号

->u的节点种类(根、内部节点、叶)

->u的父节点编号

->u的子节点编号

->u的深度

该题解决方法可采用左孩子右兄弟表示法来表示树。

左子右兄弟表示法的各节点具有以下信息

节点u的父节点

节点u最左侧的子节点

节点u右侧紧邻的节点

设树高为h,如果从各个节点出发依次寻找父节点算法的时间复杂度为O(nh),非本题正解

于是主要还是解决算法复杂度的问题,这里可以用递归计算深度的算法,

让给节点只遍历一次,算法复杂度为O(n)

代码如下

#include<bits/stdc++.h>
using namespace std;
#define MAX 100005
#define null -1
struct node{
	int p,l,r;
}t[MAX];
int n,dep[MAX];
//打印信息 
void print(int u)
{
	int i,c;
	cout<<"node"<<u<<":";
	cout<<"parent = "<<t[u].p<<", ";
	cout<<"depth = " <<dep[u]<<", ";
	
	if(t[u].p==null) cout<<"root, ";
	else if(t[u].l==null) cout<<"leaf, ";
	else cout<<"internal node ,";
	
	cout<<"[";
	
	for(i=0,c=t[u].l;c!=null;i++,c=t[c].r){
		if(i) cout<<", ";
		cout<<c;
	}
	cout<<"]"<<endl;
}
//递归计算节点的深度 
void jisuandepth(int u,int p)
{
	dep[u]=p;
	if(t[u].r!=null) jisuandepth(t[u].r,p);  //右侧兄弟设置为相同深度 
	if(t[u].l!=null) jisuandepth(t[u].l,p+1); //最左侧子节点的深度设置为自己的深度+1 
}
signed main()
{
	int i,j,d,v,c,l,r;
	cin>>n;
	for(i=0;i<n;i++) t[i].p=t[i].l=t[i].r=null;
	
	for(i=0;i<n;i++)
	{
		cin>>v>>d;
		for(j=0;j<d;j++){
			cin>>c;
			if(j==0) t[v].l=c;
			else t[l].r=c;
			l=c;
			t[c].p=v;
		}
	 }
	 for(int i=0;i<n;i++)
	 {
	 	if(t[i].p==null) r=i;
	  }
	  jisuandepth(r,0);
	  for(int i=0;i<n;i++)
	  {
	  	print(i);
	  }
	return 0;
}

  • 39
    点赞
  • 6
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值