YTU 2989问题 A: 顺序表基本运算(线性表)

题目描述

编写一个程序,实现顺序表的各种基本运算(假设顺序表的元素类型为 char),主函数已给出,请补充每一种方法。

  1. 初始化顺序表 LLL;
  2. 采用尾插法插入一个元素;
  3. 输出顺序表 LLL;
  4. 输出顺序表 LLL 的长度;
  5. 判断顺序表是否为空;
  6. 输出顺序表 LLL 的第三个元素;
  7. 输出元素 aaa 的位置;
  8. 在第四个元素位置插入元素 fff;
  9. 输出顺序表 LLL;
  10. 删除 LLL 的第三个元素;
  11. 输出顺序表 LLL;
  12. 释放顺序表 LLL。

数据元素类型定义为:

typedef char ElemType;

顺序表的定义为:

typedef struct
{
    ElemType data[SizeMax];
    int length;
} SqList;

主函数:

int main()
{
    SqList *L;
    InitList(L);                            //初始化顺序表
    ElemType a,b,c,d,e;
    scanf("%c %c %c %c %c%*c",&a,&b,&c,&d,&e);
    // 使用尾插法插入元素a,b,c,d,e
    Insert(L, a);
    Insert(L, b);
    Insert(L, c);
    Insert(L, d);
    Insert(L, e);
    // 输出顺序表
    Print(L); 
    // 输出顺序表长度
    PrintLength(L);
    // 判断顺序表是否为空
    if (SqNull(L))
    {
         printf("顺序表不为空\n");
    }
    else
    {
        printf("顺序表为空\n");
    }
    PrintData(L, 3);                        //输出第三个元素
    printf("元素a的位置:%d\n", Find(L, a));  //输出元素 a 的位置
    ElemType f;
    scanf("%c",&f);
    Insertinto(L,4,f);                      //将 f 插入到第四个位置
    Print(L);                               //输出顺序表
    Delete(L,3);                            //删除第三个元素
    Print(L);                               //输出顺序表
    free(L);                                //释放内存
    return 0;
}

输入

第一行输入五个元素 a,b,c,d,ea, b, c, d, ea,b,c,d,e,接下来输入元素 fff。

输出

按题意输出。

输入输出样例

样例输入 #1
1 2 3 4 5
6
样例输出 #1
1 2 3 4 5
5
顺序表不为空
3
元素a的位置:1
1 2 3 6 4 5
1 2 6 4 5

答案如下(请用C++):

#include <stdio.h>  
#include <stdlib.h>  
#define SizeMax 10  
typedef char ElemType;  
typedef struct  
{  
    ElemType data[SizeMax];  
    int length;  
} SqList;  
void InitList(SqList *&L)  
{  
    L=(SqList*)malloc(sizeof(SqList));  
    L->length=0;  
}  
void Insert(SqList *&L,ElemType n)  
{  
    L->data[L->length]=n;  
    L->length++;  
}  
void Print(SqList *L)  
{  
    for(int i=0; i<L->length; i++)  
        printf(i!=L->length-1?"%c ":"%c\n",L->data[i]);  
}  
void PrintLength(SqList *L)  
{  
    printf("%d\n",L->length);  
}  
bool SqNull(SqList *L)  
{  
    if(L->length)return 1;  
    return 0;  
}  
void PrintData(SqList *L,int n)  
{  
    if(L->length<n)return;  
    printf("%c\n",L->data[n-1]);  
}  
int Find(SqList *L,ElemType a)  
{  
    for(int i=0; i<L->length; i++)  
        if(L->data[i]==a)return i+1;  
    return 0;  
}  
void Insertinto(SqList *&L,int n,ElemType f)  
{  
    for(int i=L->length; i>=n; i--)  
        L->data[i]=L->data[i-1];  
    L->data[n-1]=f;  
    L->length++;  
}  
void Delete(SqList *&L,int n)  
{  
    for(int i=n-1; i<L->length-1; i++)  
        L->data[i]=L->data[i+1];  
    L->length--;  
}  
int main()  
{  
    SqList *L;  
    InitList(L);                            //初始化顺序表  
    ElemType a,b,c,d,e;  
    scanf("%c %c %c %c %c%*c",&a,&b,&c,&d,&e);  
    Insert(L,a);  
    Insert(L,b);  
    Insert(L,c);  
    Insert(L,d);  
    Insert(L,e);                            //使用尾插法插入元素a,b,c,d,e  
    Print(L);                               //输出顺序表  
    PrintLength(L);                         //输出顺序表长度  
    if(SqNull(L))  
        printf("顺序表不为空\n");  
    else printf("顺序表为空\n");            //判断顺序表是否为空  
    PrintData(L,3);                         //输出第三个元素  
    printf("元素a的位置:%d\n",Find(L,a));  //输出元素a的位置  
    ElemType f;  
    scanf("%c",&f);  
    Insertinto(L,4,f);                      //将f插入到第四个位置  
    Print(L);                               //输出顺序表  
    Delete(L,3);                            //删除第三个元素  
    Print(L);                               //输出顺序表  
    free(L);                                //释放内存  
    return 0;  
}  

周末愉快!! !

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值