CF1899C Yarik and Array (最大子段和DP)

Yarik and Array

题面翻译

题目描述

给定一个数组,求数组中连续子数组之和的最大值,但要求子数组必须满足:相邻两项奇偶性不同

输出最大总和。

输入描述

输入一个整数,第一行一个整数 t t t 代表测试样例的组数,

接下来 2 × t 2 \times t 2×t 行中,第一行输入一个整数 n n n,第二行输入 n n n 个整数表示数组。

输出描述

输出 t t t 行,每行一个整数表示答案。

translated by @Liyiyang1123

题目描述

A subarray is a continuous part of array.

Yarik recently found an array $ a $ of $ n $ elements and became very interested in finding the maximum sum of a non empty subarray. However, Yarik doesn’t like consecutive integers with the same parity, so the subarray he chooses must have alternating parities for adjacent elements.

For example, $ [1, 2, 3] $ is acceptable, but $ [1, 2, 4] $ is not, as $ 2 $ and $ 4 $ are both even and adjacent.

You need to help Yarik by finding the maximum sum of such a subarray.

输入格式

The first line contains an integer $ t $ $ (1 \le t \le 10^4) $ — number of test cases. Each test case is described as follows.

The first line of each test case contains an integer $ n $ $ (1 \le n \le 2 \cdot 10^5) $ — length of the array.

The second line of each test case contains $ n $ integers $ a_1, a_2, \dots, a_n $ $ (-10^3 \le a_i \le 10^3) $ — elements of the array.

It is guaranteed that the sum of $ n $ for all test cases does not exceed $ 2 \cdot 10^5 $ .

输出格式

For each test case, output a single integer — the answer to the problem.

样例 #1

样例输入 #1

7
5
1 2 3 4 5
4
9 9 8 8
6
-1 4 -1 0 5 -4
4
-1 2 4 -3
1
-1000
3
101 -99 101
20
-10 5 -8 10 6 -10 7 9 -2 -6 7 2 -4 6 -1 7 -6 -7 4 1

样例输出 #1

15
17
8
4
-1000
101
10

这种求子数组的最大和的问题不难想到最大子段和。
那么这道题就是在最大子段和的基础上加了一层限制:必须奇偶相间。

那么也只需要在代码中做一些稍微的改变就好了。


CODE:

#include<bits/stdc++.h>
using namespace std;
const int N = 2e5+10;

int a[N];

void solve(){
    int n;cin >> n;
    int flag = 0;
    for(int i = 1;i <= n;i++){cin >> a[i];if(a[i] > 0)flag = 1;}

    int res = -2e9;
    for(int i = 1;i <= n;i++)res = max(res,a[i]);
    if(!flag){
        cout << res << endl;
        return;
    }    
    
    int now = 0;
    //这里加了一点贪心的思想,只选正数当做子数组的开头
    for(int i = 1;i <= n;i++){
        if(now > 0){
            if((!(a[i-1]&1) && (a[i]&1)) || ((a[i-1]&1) && !(a[i]&1))){
                now += a[i];
            }else{
                if(a[i] > 0)now = a[i];
                else now = 0;
            }
        }else if(a[i] > 0)now = a[i];
        
        now = max(now,a[i]);
        res = max(res,now);
    }

    cout << res << endl;
}

int main(){
    int T;cin >> T;
    while(T--){
        solve();
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值