题目描述
Theatre Square in the capital city of Berland has a rectangular shape with the size n × m meters. On the occasion of the city's anniversary, a decision was taken to pave the Square with square granite flagstones. Each flagstone is of the size a × a.
What is the least number of flagstones needed to pave the Square? It's allowed to cover the surface larger than the Theatre Square, but the Square has to be covered. It's not allowed to break the flagstones. The sides of flagstones should be parallel to the sides of the Square.
输入
The input contains three positive integer numbers in the first line: n, m and a (1 ≤ n, m, a ≤ 109).
输出
Write the needed number of flagstones.
样例输入
6 6 4
样例输出
4
代码如下:
#include<stdio.h>
int main()
{
long long n, m, a, c, k, sum;
scanf("%lld%lld%lld", &n, &m, &a);
if (n % a == 0)//长正好铺满,则取整
{
c = n / a;
}
else//否则,多往外铺,保证全部覆盖
{
c = n / a + 1;
}
if (m % a == 0)//
{
k = m / a;
}
else
{
k = m / a + 1;
}
sum = c * k;
printf("%lld", sum);
return 0;
}