Theatre Square#C语言

题目描述

Theatre Square in the capital city of Berland has a rectangular shape with the size n × m meters. On the occasion of the city's anniversary, a decision was taken to pave the Square with square granite flagstones. Each flagstone is of the size a × a.
What is the least number of flagstones needed to pave the Square? It's allowed to cover the surface larger than the Theatre Square, but the Square has to be covered. It's not allowed to break the flagstones. The sides of flagstones should be parallel to the sides of the Square.
 

输入

The input contains three positive integer numbers in the first line: n,  m and a (1 ≤  n, m, a ≤ 109).

输出

Write the needed number of flagstones.

样例输入 
6 6 4
样例输出 
4

代码如下:

#include<stdio.h>
int main()
{
	long long n, m, a, c, k, sum;
	scanf("%lld%lld%lld", &n, &m, &a);
	if (n % a == 0)//长正好铺满,则取整
	{
		c = n / a;
	}
	else//否则,多往外铺,保证全部覆盖
	{
		c = n / a + 1;
	}
	if (m % a == 0)//
	{
		k = m / a;
	}
	else 
	{
		k = m / a + 1;
	}
	sum = c * k;
	printf("%lld", sum);
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

念帝

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值