横截面图上的区域【东北大学oj数据结构3-4】C++

你的任务是模拟洪水灾害。
对于给定的横截面图,给出淹没部分的面积。

假设该地区不断地下雨,而从该地区溢出的水正在落入两侧的海中。 例如,对于上面的横截面图,雨水将产生洪水,其面积分别为 4、2、1、19 和 9。

输入

在一行中给出一个字符串,分别用/,\_表示斜坡和平原。
例如,上面例子的区域由字符串“\ \ / / / \ _ / \ / \ \ \ \ / _ / \ \ / / / _ _ \ \ \ _ \ \ / _ \ / _ / ”给出。

输出

按以下格式输出:
A K
L1​,L2​,…,Lk​
在第一行,打印出洪水区域的总面积A。
在第二行,打印出洪水区域的个数K和每个区域的面积Li​(从左到右)。

约束

1 ≤ length of the string ≤ 20000

输入样例

\\///\_/\/\\\\/_/\\///__\\\_\\/_\/_/\

输出样例

35

5 4 2 1 19 9 

C++直接用栈类太方便了 

#include <iostream>
#include <algorithm>
#include <string>
#include <vector>
#include <stack>
using namespace std;
typedef struct A
{
    int lleft;
    int carea;
};
int main()
{
    string input;
    cin>>input;
    stack<int> s;
    stack<A> a;
    vector<int> areas;
    int totalArea=0;
 
    for(int i=0;i<input.length();i++)
    {
        if(input[i]=='\\')
        {
            s.push(i);
        }
        else if(input[i]=='/'&&!s.empty())
        {
            int left=s.top();
            s.pop();
            int width=i-left;
            totalArea+=width;
 
            while (!a.empty() && a.top().lleft> left) {
                width+=a.top().carea;
                a.pop();
            }
            a.push({left,width});
 
        }
    }
    while (a.size() > 0) {
		areas.push_back(a.top().carea);
		a.pop();
	}
	reverse(areas.begin(), areas.end());
    cout<<totalArea<<endl;
    cout<<areas.size();
    for(int i=0;i<areas.size();i++)
    {
        cout<<" "<<areas[i];
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值