目录
1.首先我们需要创建VLAN:
在AC设备上创建管理VLAN和业务VLAN。使用命令 vlan [vlan-id] 创建VLAN,并为其分配一个唯一的VLAN ID。
创建管理VLAN、业务VLAN
vlan 100
name Management-VLAN
vlan 200
name Business-VLAN
2.配置IP地址:
为管理VLAN和业务VLAN配置IP地址。使用 int vlan [vlan-id] 命令进入VLAN接口视图,然后使用 ip address [ip-address] [mask] 命令为VLAN配置IP地址。
interface Vlanif100
ip address 192.168.100.1 255.255.255.0
interface Vlanif200
ip address 192.168.200.1 255.255.255.0
3.接口设置:
将连接AP的接口设置为trunk接口,并在trunk接口上允许相应的VLAN通过。使用 int [interface-name] 命令进入接口视图,然后使用 port link-type trunk 命令将接口设置为trunk接口。
使用 port trunk pvid vlan [vlan-id] 命令设置VLAN的优先级,确保数据能够正确转发。
使用 port trunk allow-pass vlan [vlan-id] 命令允许相应的VLAN通过trunk接口。
interface GigabitEthernet0/0/1
port link-type trunk
port trunk pvid vlan 100
port trunk allow-pass vlan 100 200
4.AP的配置:
将AP的管理IP地址设置为与AC设备上的管理VLAN IP地址在同一网段内,然后将其加入到相应的VLAN中。
在AP设备上,使用 int [interface-name] 命令进入接口视图,然后使用 port link-type trunk 命令将接口设置为trunk接口。
使用 port trunk allow-pass vlan [vlan-id] 命令允许管理VLAN和业务VLAN通过trunk接口。
interface Vlanif100
ip address 192.168.100.2 255.255.255.0
interface GigabitEthernet0/0/1
port link-type trunk
port trunk allow-pass vlan 100 200
5.AC的配置:
在AC上配置与WLAN相关的各项参数,包括SSID、安全设置和VAP模板。
配置AP与AC相连的静态路由。
配置CAPWAP源接口。
wlan
ssid-profile name SSID-Profile1
ssid SSID1
security wpa2-psk cipher aes
passphrase cipher aes password cipher aes your_password
vap-profile name VAP-Profile1
service-vlan 200
ssid-profile name SSID-Profile1
security-profile name Security-Profile1
6.AP上线:
启动AP并查看AP上线情况,使用命令 display ap all 查看AP状态。
安全和业务VLAN配置:
配置安全模板,例如WPA2 PSK和AES加密。
创建SSID模板和VAP模板,并将安全模板和SSID模板应用到VAP模板中。
display ap all
7.AP组和VAP配置:
创建AP组,并将VAP模板应用到AP组中。
将AP加入到AP组中。
ap-group name AP-Group1
ap ap-id 1
ap-group name AP-Group1