最全ZOJ 3204 Connect them(最短路kruscal)_zoj3204 kruscal(1),2024年最新2024年C C++开发者跳槽指南

img
img

既有适合小白学习的零基础资料,也有适合3年以上经验的小伙伴深入学习提升的进阶课程,涵盖了95%以上C C++开发知识点,真正体系化!

由于文件比较多,这里只是将部分目录截图出来,全套包含大厂面经、学习笔记、源码讲义、实战项目、大纲路线、讲解视频,并且后续会持续更新

如果你需要这些资料,可以戳这里获取

For each test case, if you can connect the computers together, output the method in in the following fomat:

ijij1 …

where ik ik (k >= 1) are the identification numbers of the two computers to be connected. All the integers must be separated by a space and there must be no extra space at the end of the line. If there are multiple solutions, output the lexicographically smallest one (see hints for the definition of “lexicography small”) If you cannot connect them, just output “-1” in the line.

Sample Input

2
3
0 2 3
2 0 5
3 5 0
2
0 0
0 0


Sample Output

1 2 1 3
-1

Hints:
A solution A is a line of p integers: a1a2, …ap.
Another solution B different from A is a line of q integers: b1b2, …bq.
A is lexicographically smaller than B if and only if:
(1) there exists a positive integer r (r <= pr <= q) such that ai = bi for all 0 < i < r and ar < br 
OR
(2) p < q and ai = bi for all 0 < i <= p


Author: CAO, Peng
Source: The 6th Zhejiang Provincial Collegiate Programming Contest

题目意思很简单,就是直接最小生成树,只是要处理一下输出的顺序。(用了下pair 做简化)

#include<cstdio>
#include<algorithm>
#include<cstring>
#include<map>
#include<queue>
#include<iostream>
#include<cmath>
#include<stack>
#include<string>
using namespace std;
struct Edge{
    int u,v,w;
}G[10005];
int f[105];
int cnt=0,cnt1=0;
int find_f(int x)
{
    return x==f[x]?x:find_f(f[x]);
}

bool cmp(Edge a,Edge b)
{
    if(a.w != b.w)
        return a.w < b.w;
    else if(a.u != b.u)
        return a.u < b.u;
    else
        return a.v < b.v;
}
pair<int,int> ans[105];   //用到pair ,默认就是先按照first再是second
void kruscal()
{
    sort(G,G+cnt,cmp);
    for(int i=0; i < cnt; i++)
    {
        if(find_f(G[i].u) != find_f(G[i].v))
        {
            ans[cnt1++]=make_pair(G[i].u,G[i].v);
            f[find_f(G[i].u)]=find_f(G[i].v);
        }
    }
}

int main()
{
    int t;
    cin>>t;
    while(t--){
        int n;
        cin>>n;
        cnt=0;


![img](https://img-blog.csdnimg.cn/img_convert/7ee8e3d570d2cd955bad1d07c47c7797.png)
![img](https://img-blog.csdnimg.cn/img_convert/54d1809fe7ce76818eeba3c57e6a3b4d.png)

**网上学习资料一大堆,但如果学到的知识不成体系,遇到问题时只是浅尝辄止,不再深入研究,那么很难做到真正的技术提升。**

**[需要这份系统化的资料的朋友,可以添加戳这里获取](https://bbs.csdn.net/topics/618668825)**


**一个人可以走的很快,但一群人才能走的更远!不论你是正从事IT行业的老鸟或是对IT行业感兴趣的新人,都欢迎加入我们的的圈子(技术交流、学习资源、职场吐槽、大厂内推、面试辅导),让我们一起学习成长!**

获取](https://bbs.csdn.net/topics/618668825)**


**一个人可以走的很快,但一群人才能走的更远!不论你是正从事IT行业的老鸟或是对IT行业感兴趣的新人,都欢迎加入我们的的圈子(技术交流、学习资源、职场吐槽、大厂内推、面试辅导),让我们一起学习成长!**

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值