OJC++【id:60】【16分】A. 出生日期排序(结构)

题目描述

要求定义一个结构体数组,包含年月日,表示每一个人的出生日期。然后对出生日期由小到大排序,并输入排序后的结果。

要求:出生日期的存储必须使用结构体,不能使用其他类型的数据结构。

要求程序全过程对出生日期的输入、访问、输出都必须使用结构。

输入

第一行输入t表示有t个出生日期

每行输入三个整数,分别表示年、月、日

依次输入t个实例

输出

按照从小到大的顺序依次输出出生日期。

IO模式

本题IO模式为标准输入/输出(Standard IO),你需要从标准输入流中读入数据,并将答案输出至标准输出流中。


输入样例1 

10\n
2000 1 1\n
2002 11 2\n
2002 11 2\n
2003 4 25\n
2004 5 2\n
2001 11 14\n
2002 12 1\n
2000 10 21\n
2002 5 5\n
2004 5 2

输出样例1

1:2000-1-1\n
2:2000-10-21\n
3:2001-11-14\n
4:2002-5-5\n
5:2002-11-2\n
6:2002-11-2\n
7:2002-12-1\n
8:2003-4-25\n
9:2004-5-2\n
10:2004-5-2

AC代码

#include<iostream>
using namespace std;
struct Birthday {
	int year, month, day;
	int index;
};

int main() {
	int t;
	cin >> t;
	Birthday *stu=new Birthday[t],temp;
	for (int i = 0; i < t; i++) {
		cin >> stu[i].year
			>> stu[i].month
			>> stu[i].day;
	    stu[i].index= stu[i].year * 10000 + stu[i].month * 100 + stu[i].day;
	}
	for (int i = 0; i < t; i++) {
		for (int j = i+1; j < t; j++) {
			if (stu[i].index > stu[j].index) {
				temp = stu[i];
				stu[i] = stu[j];
				stu[j] = temp;
			}
		}
	}
	for (int i = 0; i < t; i++) {
		cout << i+1 << ":"
			<< stu[i].year << "-"
			<< stu[i].month << "-"
			<< stu[i].day << endl;
	}
	return 0;
}

### 杭电OJ C++编程题解与解决方案 杭电OJ是一个重要的编程技能提升平台,它提供了丰富的题目资源,帮助学习者掌握基础算法数据结构以及高级编程技术[^3]。以下是针对杭电OJ上常见的C++编程问题及其解决方法的一些讨论。 #### 题目类型析 杭电OJ中的题目通常涉及以下几个方面: 1. **基本控制流**:如`for`, `while`循环的应用。 2. **数组操作**:包括一维数组和二维数组的操作。 3. **字符串处理**:涉及到字符匹配、子串提取等问题。 4. **数学逻辑**:利用数论知识解决问题。 5. **指针应用**:深入理解内存管理机制。 6. **复杂数据结构**:链表、栈、队列等的实际运用。 下面给出几个具体的例子附带相应的代码实现: #### 示例一:反转整数与原数值比较 此问题是关于如何逆向构建一个整数,验证其特定条件下的性质。 ```cpp #include <iostream> using namespace std; // 定义函数用于计算给定数字a的反序形式 int reverseInt(int a){ int res = 0; while(a != 0){ res = res * 10 + a % 10; a /= 10; } return res; } int main(){ bool found = false; for(int i = 1000; i <= 1111; ++i){ if(reverseInt(i) == i * 9){ cout << i << endl; found = true; } } if(!found){ cout << "No such number exists." << endl; } } ``` 上述程序展示了如何遍历一定范围内的所有可能值,检查它们满足某些特殊关系的能力[^1]。 #### 示例二:双指针法寻找符合条件的一对索引 当面对需要优化时间复杂度的任务时,“双指针”是一种非常有效的策略。 假设我们有一个未排序列表,目标是从其中找到两个元素使得它们之差等于指定常量k,则可以通过如下方式高效求解: ```cpp #include <vector> #include <algorithm> // sort function needed here. using namespace std; pair<int, int> findPairWithDifference(const vector<int>& nums, const int k){ pair<int,int> result(-1,-1); // Sort the array first to apply two pointer technique effectively. vector<int> sortedNums(nums); sort(sortedNums.begin(),sortedNums.end()); size_t left = 0 ; size_t right = 1 ; while( right < sortedNums.size()){ long diff = static_cast<long>(sortedNums[right]) - static_cast<long>(sortedNums[left]); if(diff == k ){ result.first=sortedNums[left]; result.second=sortedNums[right]; break; } if(diff<k )right++; else if(diff>k &&left<right-1)left++; else{ // To avoid infinite loop when both pointers are at same position and difference is zero or negative. right++; left++; } } return result; } ``` 这里采用了先排序再用双指针扫描的方法来快速定位合适的配对项[^5]。 #### 进一步探讨——环形链表检测及入口节点确定 对于更复杂的场景比如判定单链表是否存在闭环且找出这个闭合点的位置,可以采用快慢指针的技术路线。 ```cpp struct ListNode { int val; ListNode *next; ListNode(int x):val(x), next(NULL){} }; ListNode* detectCycle(ListNode *head){ if(head==NULL || head->next==NULL)return NULL; ListNode *slow=head,*fast=head; do{ slow=slow->next; fast=(fast->next!=NULL)?fast->next->next:NULL; }while(fast&&slow!=fast); if(slow!=fast||!fast)return NULL;// No cycle detected. slow=head; while(slow!=fast){ slow=slow->next; fast=fast->next; } return slow; } ``` 这段代码实现了不仅能够确认是否含有环路而且还能准确定位到入环首结点的功能[^4]。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值