问题描述:
输入一串由符号和数字组成的四则运算,输出答案。注:数字仅有0-9组成,符号由‘+’,‘-’,‘*’,‘/’;组成。
样例输入:
9+8*4+5*6+3+4/2-1
样例输出:
75
解题思路:今天课上老师介绍的压栈,弹栈法非常适合于解这种类型的题,不仅四则运算,命题公式的运算或括弧的删除等都可以用此方法,而且也不难理解。通过这道例题的解答,读者应该能基本掌握了。代码有详细注释。
#include <iostream>
#include <stack>
#include <string>
using namespace std;
int opera[6][6]= //构造运算表,其实质如下,因为'+','-','*','/'的ASCII分别为 42 43 45 47
{ // * + 0 - 0 /
{1,1,0,1,0,1}, //* 1 1 0 1 0 1
{0,1,0,1,0,0}, //+ 0 1 0 1 0 0
{0,0,0,0,0,0}, //0 0 0 0 0 0 0
{0,1,0,1,0,0}, //- 0 1 0 1 0 0
{0,0,0,0,0,0}, //0 0 0 0 0 0 0
{1,1,0,1,0,1}, //(/)1 1 0 1 0 1
};
int main()
{
stack<int>num; //该栈用来存储数字
stack<char>ope; //该栈用来存储运算符号
string str;
while(cin>>str)
{
while(!num.empty())num.pop();//清空两个栈
while(!ope.empty())ope.pop();
for(int i=0;i<(int)str.length();i++)
{
//cout<<"i: "<<i<<'\n';
if(str[i]>='0'&&str[i]<='9')num.push(str[i]-'0');//将数字压入数字栈中
else
{
// cout<<"yes: \n";
if(ope.empty()){ope.push(str[i]);continue;}//当运算符栈为空时,压入运算符
else
{
if(opera[ope.top()-'*'][str[i]-'*'])//否则用运算表判断是否栈顶元素是否可以做运算
{
int num1=num.top();num.pop();//若可以弹出数字栈中的两个元素 ,进行相应的运算
int num2=num.top();num.pop();
switch(ope.top())
{
case '+':num.push(num1+num2);break;
case '-':num.push(num2-num1);break;
case '*':num.push(num1*num2);break;
case '/':num.push(num2/num1);break;
default:break;
}
ope.pop(); //弹出运算符栈中的栈顶运算符,因为该运算符已做过运算
}
ope.push(str[i]); //将新的运算符压入栈顶
}
}
}
//最后运算符栈可能还留下了,未使用完的运算符,我们再一次进行运算
//因为此时运算符的优先顺序就如栈的排列一样了,从上到下依次递减
while(!ope.empty())
{
int num1=num.top();num.pop();
int num2=num.top();num.pop();
switch(ope.top())
{
case '+':num.push(num1+num2);break;
case '-':num.push(num2-num1);break;
case '*':num.push(num1*num2);break;
case '/':num.push(num2/num1);break;
default:break;
}
ope.pop();
}
cout<<num.top()<<'\n';//最后数字栈中的栈顶元素即为答案
}
}
//9+8*4+5*6+3+4/2-1