AtCoder ARC 084 E - Finite Encyclopedia of Integer Sequences (AtCoder 3622)

E - Finite Encyclopedia of Integer Sequences

题目传送门
Time limit : 2sec / Memory limit : 256MB
Score : 800 points

Problem Statement

In Finite Encyclopedia of Integer Sequences (FEIS), all integer sequences of lengths between 1 and N (inclusive) consisting of integers between 1 and K (inclusive) are listed.

Let the total number of sequences listed in FEIS be X. Among those sequences, find the (X⁄2)-th (rounded up to the nearest integer) lexicographically smallest one.
Constraints

1≤N,K≤3×105
N and K are integers.

Input

Input is given from Standard Input in the following format:

K N

Output

Print the (X⁄2)-th (rounded up to the nearest integer) lexicographically smallest sequence listed in FEIS, with spaces in between, where X is the total number of sequences listed in FEIS.

Sample Input 1

Copy

3 2

Sample Output 1

Copy

2 1

There are 12 sequences listed in FEIS: (1),(1,1),(1,2),(1,3),(2),(2,1),(2,2),(2,3),(3),(3,1),(3,2),(3,3). The (12⁄2=6)-th lexicographically smallest one among them is (2,1).

Sample Input 2

Copy

2 4

Sample Output 2

Copy

1 2 2 2

Sample Input 3

Copy

5 14

Sample Output 3

Copy

3 3 3 3 3 3 3 3 3 3 3 3 2 2

Solution

显然,当K是偶数的时候,中间的那个序列是k/2,k,k,k…一共n位数字;
那么K是奇数的时候呢?看似有些棘手,毕竟此处x/2还因四舍五入入了一位。找规律呀找规律……
假如n位全填(K+1)/2,此时距离我们想要的结果还差n/2位,向前数一数,暴力可过。

Code

#include <bits/stdc++.h>
#define ll long long
using namespace std;
int n,k;
int a[300000];
int main() {
    scanf("%d%d",&k,&n);
    if (k%2==0) {
        printf("%d",k/2);
        for (int i=1;i<n;++i) printf(" %d",k);
        printf("\n");
    } else {
        fill(a,a+n,(k+1)/2);
        int t=n-1;
        for (int i=0;i<n/2;++i) {
            if (a[t]!=0) a[t]--;
            else {
                a[t-1]--;
                a[t]=k;
                if (a[t-1]!=0) t=n-1;
                else t--;//下一步还会再处理的
            }
        }
        for (int i=0;i<n;++i) {
            printf("%d",a[i]);
            if (a[i+1]!=0) printf(" ");
            else break;
        }
        printf("\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值