UVa 10420 - List of Conquests

Problem B
List of Conquests
Input:
standard input
Output:
standard output
Time Limit:
2 seconds

In Act I, Leporello is telling Donna Elvira about his master's long list of conquests:

``This is the list of the beauties my master has loved, a list I've made out myself: take a look, read it with me. In Italy six hundred and forty, in Germany two hundred and thirty-one, a hundred in France, ninety-one in Turkey; but in Spain already a thousand and three! Among them are country girls, waiting-maids, city beauties; there are countesses, baronesses, marchionesses, princesses: women of every rank, of every size, of every age.'' (Madamina, il catalogo è questo)

As Leporello records all the ``beauties'' Don Giovanni ``loved'' in chronological order, it is very troublesome for him to present his master's conquest to others because he needs to count the number of ``beauties'' by their nationality each time. You are to help Leporello to count.

Input

The input consists of at most 2000lines, but the first. The first line contains a numbern, indicating that there will be nmore lines. Each following line, with at most75 characters, contains a country (the first word) and the name of a woman (the rest of the words in the line) Giovanni loved. You may assume that the name of all countries consist of only one word.

Output

The output consists of lines in alphabetical order. Each line starts with the name of a country, followed by the total number of women Giovanni loved in that country, separated by a space.

Sample Input

3
Spain Donna Elvira
England Jane Doe
Spain Donna Anna

Sample Output

England 1

Spain 2


Problem-setter:Thomas Tang, Queens University, Canada

“Failure to produce a reasonably good and error free problem set illustrates two things a) Lack of creativity b) Lack of commitment”

这道题需要判断出现的字符串在地区相同的情况下,要判断人名是否相同,如果不判断就会出现超时的现象。

#include <stdio.h>
#include <string.h>
struct num
{
    char s[100];
    int sum;
}a[2010];
int cmp(const void *a,const void *b)
{
    struct num *p1,*p2;
    p1=(struct num *)a;
    p2=(struct num *)b;
    return (strcmp(p1->s,p2->s));
}
int main()
{
    int i,j,n,m,s,t;
    char s2[2000][100],s3[2000][100];
    scanf("%d",&n);
    for(i=0;i<=n-1;)
    {
        scanf("%s",s2[i]);
        gets(s3[i]);
        for(j=0;j<=i-1;j++)
        {
           if(strcmp(s2[i],s2[j])==0&&strcmp(s3[i],s3[j])==0)
            {
                break;
            }
         }
         if(j==i)
         {
            i+=1;
        }
    }
    n=i;
    int flag;
    flag=0;
    for(i=0;i<=n-1;i++)
    {
        if(flag==0)
        {
            strcpy(a[flag].s,s2[i]);
            a[flag].sum=1;
            flag+=1;
        }else
        {
            for(j=0;j<=flag-1;j++)
            {
                if(strcmp(a[j].s,s2[i])==0)
                {
                    break;
                }
            }
            if(j==flag)
            {
                strcpy(a[flag].s,s2[i]);
                a[flag].sum=1;
                flag+=1;
            }else
            {
                a[j].sum+=1;
            }
        }
    }
    n=flag;
    qsort(a,n,sizeof(a[0]),cmp);
    for(i=0;i<=n-1;i++)
    {
        printf("%s %d\n",a[i].s,a[i].sum);
    }
    return 0;

}


 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值