POJ 3070 Fibonacci

Fibonacci
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 8202 Accepted: 5835

Description

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is

.

Given an integer n, your goal is to compute the last 4 digits of Fn.

Input

The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

Output

For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

Sample Input

0
9
999999999
1000000000
-1

Sample Output

0
34
626
6875

Hint

As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by

.

Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:

.

Source

   这题幸运的是:在题目的描述中就给了计算的公式了,用快速幂取模就可以了
#include <iostream>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <algorithm>
#define mod 10000
using namespace std;
__int64 a,b,c,d;
int main()
{
    //freopen("data.in","r",stdin);
    __int64 f(__int64 n);
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        if(n==-1)
        {
            break;
        }
        if(n==0)
        {
            printf("0\n");
            continue;
        }else if(n==1)
        {
            printf("1\n");
            continue;
        }
        a = 0;
        b = 1;
        c = 1;
        d = 1;
        __int64 ans = f(n);
        printf("%I64d\n",ans);
    }
    return 0;
}
__int64 f(__int64 n)
{
    __int64 a1=1,b1=0,c1=1,d1=0;
    __int64 a2,b2,c2,d2;
    while(n>1)
    {
        if(n&1)
        {
            c2 = ((c*c1)%mod+(b*d1)%mod)%mod;
            b2 = ((c*b1)%mod+(b*a1)%mod)%mod;
            d2 = ((d*c1)%mod+(a*d1)%mod)%mod;
            a2 = ((d*b1)%mod+(a*a1)%mod)%mod;
            a1 = a2;
            b1 = b2;
            c1 = c2;
            d1 = d2;
        }
        c2 = ((c*c)%mod+(b*d)%mod)%mod;
        b2 = ((c*b)%mod+(b*a)%mod)%mod;
        d2 = ((d*c)%mod+(a*d)%mod)%mod;
        a2 = ((d*b)%mod+(a*a)%mod)%mod;
        a = a2;
        b = b2;
        c = c2;
        d = d2;
        n = n>>1;
    }
    c2 = ((c*c1)%mod+(b*d1)%mod)%mod;
    b2 = ((c*b1)%mod+(b*a1)%mod)%mod;
    d2 = ((d*c1)%mod+(a*d1)%mod)%mod;
    a2 = ((d*b1)%mod+(a*a1)%mod)%mod;
    a1 = a2;
    b1 = b2;
    c1 = c2;
    d1 = d2;
    return b1;

}


评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值