杭电 factorials

factorials

Time Limit : 3000/1000ms (Java/Other)   Memory Limit : 65535/32768K (Java/Other)
Total Submission(s) : 5   Accepted Submission(s) : 2
Font: Times New Roman | Verdana | Georgia
Font Size: ← →

Problem Description

AmzMohammad Loves factorial ! and now selected this problem for U !

Factorial of an integer is defined by the following function

f(0) = 1
f(n) = f(n - 1) * n, if(n > 0)

So, factorial of 5 is 120. But in different bases, the factorial may be different. For example, factorial of 5 in base 8 is 170.

In this problem, you have to find the number of digit(s) of the factorial of an integer in a certain base.

Input

Input starts with an integer T (≤ 50000), denoting the number of test cases.

Each case begins with two integers n (0 ≤ n ≤ 106) and base (2 ≤ base ≤ 1000). Both of these integers will be given in decimal.

Output

For each case of input you have to print the case number and the digit(s) of factorial n in the given base.

Sample Input

5
5 10
8 10
22 3
1000000 2
0 100

Sample Output

Case 1: 3
Case 2: 5
Case 3: 45
Case 4: 18488885
Case 5: 1
#include <stdio.h>
#include <string.h>
#include <math.h>
#define PI 3.141592657
int main()
{
    int n,s1,t,k;
    double m,s;
    scanf("%d",&t);
    k=1;
    while(t--)
    {
        scanf("%d %lf",&n,&m);
        s=0;
        s=n*log(n)-n+0.5*log(2*n*PI);
        s1=(int)(s/log(m));
		s1+=1;
        if(n==0)
		{
			s1=1;
		}
        printf("Case %d: %d\n",k,s1);
        k+=1;
    }
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值