UVa 10004 - Bicoloring


  Bicoloring 

In 1976 the ``Four Color Map Theorem" was proven with the assistance of a computer. This theorem states that every map can be colored using only four colors, in such a way that no region is colored using the same color as a neighbor region.

Here you are asked to solve a simpler similar problem. You have to decide whether a given arbitrary connected graph can be bicolored. That is, if one can assign colors (from a palette of two) to the nodes in such a way that no two adjacent nodes have the same color. To simplify the problem you can assume:

  • no node will have an edge to itself.
  • the graph is nondirected. That is, if a node a is said to be connected to a node b, then you must assume that b is connected to a.
  • the graph will be strongly connected. That is, there will be at least one path from any node to any other node.

Input 

The input consists of several test cases. Each test case starts with a line containing the number  n  (  1 <  n < 200) of different nodes. The second line contains the number of edges  l . After this,  l  lines will follow, each containing two numbers that specify an edge between the two nodes that they represent. A node in the graph will be labeled using a number  a  (  $0 \le a < n$ ).

An input with n = 0 will mark the end of the input and is not to be processed.

Output 

You have to decide whether the input graph can be bicolored or not, and print it as shown below.

Sample Input 

3
3
0 1
1 2
2 0
9
8
0 1
0 2
0 3
0 4
0 5
0 6
0 7
0 8
0

Sample Output 

NOT BICOLORABLE.
BICOLORABLE.



Miguel Revilla 
2000-08-21
 
这题是用并查集做,出现回路的时候并不是不满足条件的时候,在出现回路,并且两结点之间有奇数个节点的时候,才不满足条件
#include <iostream>
#include <string.h>
#include <stdlib.h>
using namespace std;
int a[250],b[250],status[250][250];
int main()
{
    int f(int x,int y);
    int i,j,n,m,s,t;
    int x,y,k;
    while(cin>>n)
    {
        if(n==0)
        {
            break;
        }
        cin>>m;
        memset(status,0,sizeof(status));
        for(i=0;i<=n;i++)
        {
            a[i]=i;
        }
        k=0;
        while(m--)
        {
            cin>>x>>y;
            if(k==0&&status[x][y]==0)
            {
                status[x][y]=status[y][x]=1;
                k=f(x,y);
            }
        }
        if(k==0)
        {
            cout<<"BICOLORABLE."<<endl;
        }else
        {
            cout<<"NOT BICOLORABLE."<<endl;
        }
    }
    return 0;
}
int find(int x,int &s)
{
    s=0;
    while(x!=a[x])
    {
        x=a[x];
        s+=1;
    }
    return x;
}
int f(int x,int y)
{
    int k1,k2;
    x=find(x,k1);
    y=find(y,k2);
    if(x!=y)
    {
        a[x]=y;
    }else
    {
        if(abs(k1-k2-1)%2==0)
        {
            ;
        }else
        {
            return 1;
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值