POJ 3687 Labeling Balls

Labeling Balls
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 8264 Accepted: 2247

Description

Windy has N balls of distinct weights from 1 unit to N units. Now he tries to label them with 1 to N in such a way that:

  1. No two balls share the same label.
  2. The labeling satisfies several constrains like "The ball labeled with a is lighter than the one labeled with b".

Can you help windy to find a solution?

Input

The first line of input is the number of test case. The first line of each test case contains two integers, N (1 ≤ N ≤ 200) and M (0 ≤ M ≤ 40,000). The next M line each contain two integers a and b indicating the ball labeled with a must be lighter than the one labeled with b. (1 ≤ a, bN) There is a blank line before each test case.

Output

For each test case output on a single line the balls' weights from label 1 to label N. If several solutions exist, you should output the one with the smallest weight for label 1, then with the smallest weight for label 2, then with the smallest weight for label 3 and so on... If no solution exists, output -1 instead.

Sample Input

5

4 0

4 1
1 1

4 2
1 2
2 1

4 1
2 1

4 1
3 2

Sample Output

1 2 3 4
-1
-1
2 1 3 4
1 3 2 4

Source

刚看到这题的时候就有点发懵,虽然我知道这是拓扑排序但都头来还是没做出来,不断的变化思路,最终还是WA,无奈之下看了看解题报告,明白了思想,感觉特别简单。推荐大家看
很容易懂
贴一下我的代码:
#include <iostream>
#include <string>
using namespace std;
class num
{
    public:
    int end,next;
}a[1000000];
int b[210];
int status[210];
int res[210];
int in[210],out[210],n;
int main()
{
    int deal();
    int i,j,m,s,t,k;
    int x,y;
    cin>>t;
    while(t--)
    {
        cin>>n>>m;
        memset(b,-1,sizeof(b));
        memset(in,0,sizeof(in));
        memset(out,0,sizeof(out));
        k=0;
        for(i=1,j=0;i<=m;i++)
        {
            cin>>x>>y;
            in[x]+=1; out[y]+=1;
            a[j].end=x; a[j].next=b[y];
            b[y]=j; j++;
            if(x==y)
            {
                k=1;
            }
        }
        if(k)
        {
            cout<<-1<<endl;
            continue;
        }
        k=deal();
        if(!k)
        {
            cout<<-1<<endl;
        }else
        {
            for(i=1;i<=n;i++)
            {
                if(i==1)
                {
                    cout<<res[i];
                }else
                {
                    cout<<" "<<res[i];
                }
            }
            cout<<endl;
        }
    }
    return 0;
}
int deal()
{
    int i,j,k;
    memset(status,0,sizeof(status));
    for(i=n;i>=1;i--)
    {
        k=-1;
        for(j=n;j>=1;j--)
        {
            if(!in[j]&&!status[j])
            {
                k=j;
                break;
            }
        }
        if(k==-1)
        {
            return 0;
        }
        res[k]=i; status[k]=1;
        for(j=b[k];j!=-1;j=a[j].next)
        {
            in[a[j].end]-=1;
        }
    }
    return 1;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
未来社区的建设背景和需求分析指出,随着智能经济、大数据、人工智能、物联网、区块链、云计算等技术的发展,社区服务正朝着数字化、智能化转型。社区服务渠道由分散向统一融合转变,服务内容由通用庞杂向个性化、服务导向转变。未来社区将构建数字化生态,实现数据在线、组织在线、服务在线、产品智能和决策智能,赋能企业创新,同时注重人才培养和科研平台建设。 规划设计方面,未来社区将基于居民需求,打造以服务为中心的社区管理模式。通过统一的服务平台和应用,实现服务内容的整合和优化,提供灵活多样的服务方式,如推送式、订阅式、热点式等。社区将构建数据与应用的良性循环,提高服务效率,同时注重生态优美、绿色低碳、社会和谐,以实现幸福民生和产业发展。 建设运营上,未来社区强调科学规划、以人为本,创新引领、重点突破,统筹推进、整体提升。通过实施院落+社团自治工程,转变政府职能,深化社区自治法制化、信息化,解决社区治理中的重点问题。目标是培养有活力的社会组织,提高社区居民参与度和满意度,实现社区治理服务的制度机制创新。 未来社区的数字化解决方案包括信息发布系统、服务系统和管理系统。信息发布系统涵盖公共服务类和社会化服务类信息,提供政策宣传、家政服务、健康医疗咨询等功能。服务系统功能需求包括办事指南、公共服务、社区工作参与互动等,旨在提高社区服务能力。管理系统功能需求则涉及院落管理、社团管理、社工队伍管理等,以实现社区治理的现代化。 最后,未来社区建设注重整合政府、社会组织、企业等多方资源,以提高社区服务的效率和质量。通过建立社区管理服务综合信息平台,提供社区公共服务、社区社会组织管理服务和社区便民服务,实现管理精简、高效、透明,服务快速、便捷。同时,通过培育和发展社区协会、社团等组织,激发社会化组织活力,为居民提供综合性的咨询和服务,促进社区的和谐发展。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值