POJ 10341 - Solve It

Problem F

Solve It

Input: standard input

Output: standard output

Time Limit: 1 second

Memory Limit: 32 MB

Solve the equation:
        p*e-x q*sin(x) + r*cos(x) + s*tan(x) + t*x2 + u = 0
        where 0 <= x <= 1.

Input

Input consists of multiple test cases and terminated by an EOF. Each test case consists of 6 integers in a single line: pqrst and u (where0 <= p,r <= 20 and -20 <= q,s,t <= 0). There will be maximum 2100 lines in the input file.

Output

For each set of input, there should be a line containing the value of x, correct upto 4 decimal places, or the string "No solution", whichever is applicable.

Sample Input

0 0 0 0 -2 1
1 0 0 0 -1 2
1 -1 1 -1 -1 1

Sample Output

0.7071
No solution
0.7554

Mustaq Ahmed

    题目中的x是代表的弧度,而不是度数。 可以研究一下他的单调性,很容易就得出他是一个单调递减的函数。(提示:分别研究每一个小函数,就会得出,每一个小函数都是递减的,那么整个函数就是递减的) 然后剩下的就是用二分就可以了。要注意精度啊。 只是要到1e-9

#include <stdio.h>
#include <string.h>
#include <math.h>
#define EQS 1e-9
double p,q,r,s,t,u;
int k;
int main()
{
    double binary_search(double l,double r);
    int i,j,n,m;
    double x,res;
    while(scanf("%lf %lf %lf %lf %lf %lf",&p,&q,&r,&s,&t,&u)!=EOF)
    {
        k=0;
        u=u*-1;
        res=binary_search(0.0,1.0);
        if(k==1)
        {
            printf("%.4lf\n",res);
        }else
        {
            printf("No solution\n");
        }
    }
    return 0;
}
int check(double x)
{
    double check_s;
    check_s= p*exp(-1*x) + q*sin(x) + r*cos(x) + s*tan(x) + t*x*x;
    if(fabs(check_s-u)<=1e-7)
    {
        return 0;
    }else if(check_s>u)
    {
        return 1;
    }else
    {
        return -1;
    }
}
double binary_search(double l,double r)
{
    double mid;
    int t;
    while(!(r<l||fabs(l-r)<=EQS))
    {
        mid= (l+r)/2.0;
        t=check(mid);
        if(t==0)
        {
            k=1;
            return mid;
        }else if(t==-1)
        {
            r=mid;
        }else
        {
            l=mid;
        }
    }
    return -1;
}


 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值