二维树状数组模板题 poj 1195 Mobile phones

Mobile phones
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 16721 Accepted: 7692

Description

Suppose that the fourth generation mobile phone base stations in the Tampere area operate as follows. The area is divided into squares. The squares form an S * S matrix with the rows and columns numbered from 0 to S-1. Each square contains a base station. The number of active mobile phones inside a square can change because a phone is moved from a square to another or a phone is switched on or off. At times, each base station reports the change in the number of active phones to the main base station along with the row and the column of the matrix. 

Write a program, which receives these reports and answers queries about the current total number of active mobile phones in any rectangle-shaped area. 

Input

The input is read from standard input as integers and the answers to the queries are written to standard output as integers. The input is encoded as follows. Each input comes on a separate line, and consists of one instruction integer and a number of parameter integers according to the following table. 

The values will always be in range, so there is no need to check them. In particular, if A is negative, it can be assumed that it will not reduce the square value below zero. The indexing starts at 0, e.g. for a table of size 4 * 4, we have 0 <= X <= 3 and 0 <= Y <= 3. 

Table size: 1 * 1 <= S * S <= 1024 * 1024 
Cell value V at any time: 0 <= V <= 32767 
Update amount: -32768 <= A <= 32767 
No of instructions in input: 3 <= U <= 60002 
Maximum number of phones in the whole table: M= 2^30 

Output

Your program should not answer anything to lines with an instruction other than 2. If the instruction is 2, then your program is expected to answer the query by writing the answer as a single line containing a single integer to standard output.

Sample Input

0 4
1 1 2 3
2 0 0 2 2 
1 1 1 2
1 1 2 -1
2 1 1 2 3 
3

Sample Output

3
4

Source


思路: 二维树状数组

分析:
1 给定一个矩阵和三种操作 1 a b x表示把[a,b]值加上x,2 L B R T表示L <= x <= R , B <= y <= T
求这个小矩形的面积 3表示输入结束
2 简单的二维树状数组,但是这边要注意的是操作2的时候一定不能够把维度给弄反了,L R表示的是x的范围而B T表示
的是y的范围
3 题目还有一个trick就是当[a,b]加上x后如果值为负数,那么应该把值设为0

代码:

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;

const int MAXN = 1030;

int s;
int num[MAXN][MAXN];
long long treeNum[MAXN][MAXN];

int lowbit(int x){
    return x&(-x);
}

void add(int x , int y , int val){
    if(num[x][y]+val < 0)
        val = -num[x][y];    
    num[x][y] += val;    
    for(int i = x ; i < MAXN ; i += lowbit(i))
        for(int j = y ; j < MAXN ; j += lowbit(j))
            treeNum[i][j] += val; 
}

long long getSum(int x , int y){
    long long sum = 0;
    for(int i = x ; i > 0 ; i -= lowbit(i))
        for(int j = y ; j > 0 ; j -= lowbit(j))
            sum += treeNum[i][j]; 
    return sum;
}

int main(){
    int x , i , j , val;
    int l , r , u , d;
    while(scanf("%d%d" , &x , &s) != EOF){
        memset(treeNum , 0 , sizeof(treeNum));
        memset(num , 0 , sizeof(num));
        while(scanf("%d" , &x) && x != 3){
            if(x == 1){
                scanf("%d%d%d" , &i , &j , &val); 
                add(i+1 , j+1 , val);
            }
            else{
                scanf("%d%d%d%d" , &u , &l , &d , &r);
                l++ , u++ , r++ , d++;
                long long sum = getSum(d , r);
                sum -= getSum(u-1 , r);
                sum -= getSum(d , l-1);
                sum += getSum(u-1 , l-1);
                printf("%lld\n" , sum);
            }
        }
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值