UVA - 815 Flooded!

To enable homebuyers to estimate the cost of flood insurance, a real-estate firm provides clients with
the elevation of each 10-meter by 10-meter square of land in regions where homes may be purchased.
Water from rain, melting snow, and burst water mains will collect first in those squares with the
lowest elevations, since water from squares of higher elevation will run downhill. For simplicity, we also
assume that storm sewers enable water from high-elevation squares in valleys (completely enclosed by
still higher elevation squares) to drain to lower elevation squares, and that water will not be absorbed
by the land.
From weather data archives, we know the typical volume of water that collects in a region. As
prospective homebuyers, we wish to know the elevation of the water after it has collected in lowlying
squares, and also the percentage of the region’s area that is completely submerged (that is, the
percentage of 10-meter squares whose elevation is strictly less than the water level). You are to write
the program that provides these results.
Input
The input consists of a sequence of region descriptions. Each begins with a pair of integers, m and
n, each less than 30, giving the dimensions of the rectangular region in 10-meter units. Immediately
following are m lines of n integers giving the elevations of the squares in row-major order. Elevations
are given in meters, with positive and negative numbers representing elevations above and below sea
level, respectively. The final value in each region description is an integer that indicates the number of
cubic meters of water that will collect in the region. A pair of zeroes follows the description of the last
region.
Output
For each region, display the region number (1, 2, . . . ), the water level (in meters above or below sea
level) and the percentage of the region’s area under water, each on a separate line. The water level
and percentage of the region’s area under water are to be displayed accurate to two fractional digits.
Follow the output for each region with a blank line.
Sample Input
3 3
25 37 45
51 12 34
94 83 27
10000
0 0
Sample Output
Region 1
Water level is 46.67 meters.

66.67 percent of the region is under water.

先按照高度从小到大的顺序对所有方格进行排序。然后一步一步模拟水淹没一个又一个方格的过程。当水量超过给定量的时候,跳出循环。如果是由于方格全部淹没导致跳出循环的需要另外处理。

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
double a[1000];//转换成一维数组
int main()
{
double now,n,m,water;
int kase=0;
while(cin>>m>>n)
{
     int i;
    if(m==0&&n==0)
        break;
   for( i=1;i<=m*n;i++)
    cin>>a[i];
   cin>>water;
   water/=100;//除以每个方格的面积
   now=0;
   double high,percent;
   int sum=m*n;
    sort(a+1,a+sum+1);
    a[0]=a[1];//为了计算水淹没的高度,以最低的方格为参考平面
    for(i=1;i<=m*n;i++)
        a[i]-=a[0];
    for( i=2;i<=m*n;i++)
        {now+=(a[i]-a[i-1])*(i-1);//依次模拟水淹没方格
        if(now>water) break;
        }
        if(i!=m*n+1)
        {
            now-=(a[i]-a[i-1])*(i-1);
            high=a[i-1]+(water-now)/(i-1)+a[0];//多余的水量无法淹没整块方格。计算淹没的高度
 percent=(i-1)/(m*n)*100;
        }
        else{
            high=a[sum]+(water-now)/(m*n)+a[0];//淹没完了所有方格,计算在这之后还会淹没多高
            percent=100;
        }
        printf("Region %d\n",++kase);
printf("Water level is %.2f meters.\n",high);
printf("%.2f percent of the region is under water.\n\n",percent);
}
return 0;
}

利用 TensorFlow 训练自己的目标识别器。本文内容来自于我的毕业设计,基于 TensorFlow 1.15.0,其他 TensorFlow 版本运行可能存在问题。.zip项目工程资源经过严格测试可直接运行成功且功能正常的情况才上传,可轻松复刻,拿到资料包后可轻松复现出一样的项目,本人系统开发经验充足(全领域),有任何使用问题欢迎随时与我联系,我会及时为您解惑,提供帮助。 【资源内容】:包含完整源码+工程文件+说明(如有)等。答辩评审平均分达到96分,放心下载使用!可轻松复现,设计报告也可借鉴此项目,该资源内项目代码都经过测试运行成功,功能ok的情况下才上传的。 【提供帮助】:有任何使用问题欢迎随时与我联系,我会及时解答解惑,提供帮助 【附带帮助】:若还需要相关开发工具、学习资料等,我会提供帮助,提供资料,鼓励学习进步 【项目价值】:可用在相关项目设计中,皆可应用在项目、毕业设计、课程设计、期末/期中/大作业、工程实训、大创等学科竞赛比赛、初期项目立项、学习/练手等方面,可借鉴此优质项目实现复刻,设计报告也可借鉴此项目,也可基于此项目来扩展开发出更多功能 下载后请首先打开README文件(如有),项目工程可直接复现复刻,如果基础还行,也可在此程序基础上进行修改,以实现其它功能。供开源学习/技术交流/学习参考,勿用于商业用途。质量优质,放心下载使用。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值