hdu 1005 Number Sequence

Number Sequence
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 140213 Accepted Submission(s): 33999

Problem Description

A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).

Input

The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.

Output

For each test case, print the value of f(n) on a single line.

Sample Input

1 1 3
1 2 10
0 0 0

Sample Output

2
5

题解:这题看上去就很熟悉,以前就遇到这种取模的题,取模很容易造成周期,所以就把数据打出来看了下,果然是的吗,然后就取了个周期就AC了,周期取大点没关系,取小了就不行了!
还有方法就是 快速矩阵做,如果快速矩阵不会,可以先看下快速幂,时间为long(n).

这里写代码片
#include<iostream>
#include<cstring>
#include<string>
using namespace std;
long long int aa[100];
int  main()
{
    aa[1]=1,aa[2]=1;
    int a,b,n;
    while(cin>>a>>b>>n,(a+b+n))
    {                                                                                                                                                          
        for(int i=3;i<=51;i++)
        aa[i]=(a*aa[i-1]+b*aa[i-2])%7;
        int d=n%51;
        cout<<aa[d]<<endl;
    } 
    return 0;
}

快速矩阵做://自己正在做其他题,不写了!

这里写代码片
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
struct Matrix
{
    int m[2][2];
}E,A;
void init()
{
    for(int i=0;i<2;i++)
    for(int j=0;j<2;j++)
    E.m[i][j]=(i==j);
}
Matrix Mut(Matrix A,Matrix B,int mod)
{
    Matrix ans;
    int i,j,k;
    for(i=0;i<2;i++)
    for(j=0;j<2;j++)
    {
        ans.m[i][j]=0;
        for(k=0;k<2;k++)
        ans.m[i][j]=(ans.m[i][j]+(A.m[i][k]%mod)*(B.m[k][j]%mod))%mod;
    }
    return ans;
}
Matrix quick(Matrix A,int n,int mod)
{
    Matrix t=A,d=E;
    while(n)
    {
        if(n%2) d=Mut(d,t,mod);
        n/=2;
        t=Mut(t,t,mod);
    }
    return d;
}
int main()
{
    init();
    int a,b,n;
    while(scanf("%d%d%d",&a,&b,&n)!=EOF)
    {
        if(a==0&&b==0&&n==0)
        break;
        if(n==1||n==2)
        {
            printf("1\n");
        }
        else
        {
            A.m[0][0]=a;
            A.m[0][1]=b;
            A.m[1][0]=1;
            A.m[1][1]=0;
            Matrix ans=quick(A,n-2,7);
            printf("%d\n",(ans.m[0][0]+ans.m[0][1])%7);
        }
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值