hdu1379DNA Sorting

Problem Description
One measure of unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequenceDAABEC”, this measure is 5, since D is greater than four letters to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence AACEDGG'' has only one inversion (E and D)--it is nearly sorted--while the sequenceZWQM” has 6 inversions (it is as unsorted as can be–exactly the reverse of sorted).

You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of sortedness'', frommost sorted” to “least sorted”. All the strings are of the same length.

This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.

Input
The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (1 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string of length n.

Output
Output the list of input strings, arranged from most sorted'' toleast sorted”. If two or more strings are equally sorted, list them in the same order they are in the input file.

Sample Input

1

10 6
AACATGAAGG
TTTTGGCCAA
TTTGGCCAAA
GATCAGATTT
CCCGGGGGGA
ATCGATGCAT

Sample Output

CCCGGGGGGA
AACATGAAGG
GATCAGATTT
ATCGATGCAT
TTTTGGCCAA
TTTGGCCAAA

分析:简单水题,数据很小。唯一要注意的是,格式问题,我pe了一次。

#include<iostream>
#include<cstring>
#include<string>
#include<algorithm>
#include<cmath>
using namespace std;
int n,m;

struct p{
    int id;
    int ve;
    char s[55];
}vis[105];

bool cmp1(p a,p b)
{
    if(a.ve !=b.ve )
    return a.ve<b.ve;
    else
    return a.id <b.id ;
}


 void slove()
   {
      for(int i=0;i<m;i++)
      {
        vis[i].ve=0,vis[i].id=i;
         for(int j=n-1;j>=0;j--)
         {
              for(int k=j-1;k>=0;k--)
              {
                if(vis[i].s[j]<vis[i].s[k])
                 vis[i].ve++; 
                }
        }
        }
   }
int main()
{
    int t;
    while(t--)
    {
        getchar();
      scanf("%d %d",&n,&m);
        for(int i=0;i<m;i++)
        {
            scanf("%s",&vis[i].s );
        }
        slove();
        sort(vis,vis+m,cmp1);
        for(int i=0;i<m;i++)
        {
            cout<<vis[i].s<<endl;
        }
}
    return 0;
 } 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值