hdu 5675 ztr loves math

Problem Description
ztr loves research Math.One day,He thought about the “Lower Edition” of triangle equation set.Such as n=x2−y2.

He wanted to know that ,for a given number n,is there a positive integer solutions?

Input
There are T test cases.
The first line of input contains an positive integer T(T<=106) indicating the number of test cases.

For each test case:each line contains a positive integer ,n<=1018.

Output
If there be a positive integer solutions,print True,else print False

Sample Input

4
6
25
81
105

Sample Output

False
True
True
True

Hint
For the fourth case, 105=13282
分析:由于n达到10^18,暴力的话也不好做。 n=(k+x)2(k)2 ,即 n=2xk+k2 .当n为奇数,x=1,k=1,n最小为3;n为任意大于3的奇数都可表达。当n为偶数时,x=1,k=2,最小n=8。把 k=2m 代入,得 n=4(xm+m) .得n为4的倍数。

 #include<iostream>
 #include<algorithm>
 #include<string>
 #include<cstring>
 #include<cmath>
 #include<set>
 using namespace std;

 int main()
 {
    int n;
    scanf("%d",&n);
    long long t;
    while(n--)
    {
        scanf("%lld",&t);
        int flag=0;
        if(t%2!=0&&t>=3)
        flag=1;
        else if(t%4==0&&t>=8)
        flag=1;
        if(!flag)
        cout<<"False"<<endl;
        else
        cout<<"True"<<endl; 
     }
     return 0;
  } 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值