poj 2078 Matrix

Description
Given an n*n matrix A, whose entries Ai,j are integer numbers ( 0 <= i < n, 0 <= j < n ). An operation SHIFT at row i ( 0 <= i < n ) will move the integers in the row one position right, and the rightmost integer will wrap around to the leftmost column.

You can do the SHIFT operation at arbitrary row, and as many times as you like. Your task is to minimize
max0<=j< n{Cj|Cj=Σ0<=i< nAi,j}

Input
The input consists of several test cases. The first line of each test case contains an integer n. Each of the following n lines contains n integers, indicating the matrix A. The input is terminated by a single line with an integer −1. You may assume that 1 <= n <= 7 and |Ai,j| < 104.

Output
For each test case, print a line containing the minimum value of the maximum of column sums.

Sample Input

2
4 6
3 7
3
1 2 3
4 5 6
7 8 9
-1

Sample Output

11
15
好久没写搜索了额,总算是写出来了吧!

#include<iostream>
#include<cstring>
#include<string>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<queue>
#include<map>
#include<set>
using namespace std;
int a[10][10];
int n,mini,maxi;
void shift(int k){
    int kk=a[k][n-1];
    for(int i=n-1;i>=1;i--)
        a[k][i]=a[k][i-1];
        a[k][0]=kk;
}
void dfs(int co){             对行搜索
    if(co==n)
        return ;
        maxi=-9999999;
        for(int ii=0;ii<n;ii++){
                int sum=0;
            for(int jj=0;jj<n;jj++)
                 sum+=a[jj][ii];
                maxi=max(sum,maxi);
        }
        mini=min(maxi,mini);
        for(int ii=0;ii<n;ii++){ 对每行shift n-1次
            shift(co+1);
            dfs(co+1);
        }
}
int main(){
    while(scanf("%d",&n)!=EOF&&n!=-1){
        mini=99999999,maxi=-99999999;
        for(int i=0;i<n;i++)
            for(int j=0;j<n;j++)
                scanf("%d",&a[i][j]);
         dfs(0);
         printf("%d\n",mini);
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值