G - Tempter of the Bone

G - Tempter of the Bone
Crawling in process... Crawling failed Time Limit:2000MS    Memory Limit:65536KB     64bit IO Format:%lld & %llu

Description

The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.


Input

The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:

'X': a block of wall, which the doggie cannot enter;
'S': the start point of the doggie;
'D': the Door; or
'.': an empty block.

The input is terminated with three 0's. This test case is not to be processed.


Output

For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.


Sample Input

4 4 5
S.X.
..X.
..XD
....
3 4 5
S.X.
..X.
...D
0 0 0


Sample Output


NO
YES

简单的dfs深搜,注意这里用bfs是不可以的。

只要注意逻辑关系和return的返回地点就好了

首先附上自己的错误代码:

#include<stdio.h>
#include<string.h>
char a[51][51];
int book[51][51],n,m,min=9999999;
int p,q,startx,starty,t,flag=0,s=0;
void dfs(int x,int y,int step){
	int next[4][2]={{0,1},{1,0},{0,-1},{-1,0}};
	int k,tx=0,ty=0;
	if(x==p && y==q){
		return ;
	}
	for(k=0;k<=3;k++){
		tx=x+next[k][0];
		ty=y+next[k][1];
		if(tx<0||tx>n-1||ty<0||ty>m-1)
			continue;
		if(a[tx][ty]=='.' && book[tx][ty]==0){
			book[tx][ty]=1;
			dfs(tx,ty,step+1);
			//printf("%d\n",step);
			if(step==t)  {flag=1; s=step;}
			book[tx][ty]=0;
		}
	}
	return ;
}
int main(){
	int i,j,k;
	while(scanf("%d%d%d",&n,&m,&t)!=EOF){
		if(n==0 && m==0 && t==0)  break;
		memset(book,0,sizeof(book));
		for(i=0;i<n;i++){
			scanf("%s",a[i]);
		}
		for(i=0;i<n;i++){
			for(j=0;j<m;j++){
				if(a[i][j]=='S')  {startx=i; starty=j;}
				if(a[i][j]=='D')  {p=i; q=j;}
			}
		}
		book[startx][starty]=1;
		s=0; flag=0;
		dfs(startx,starty,0);
		if(s==t && flag) puts("YES");
		else puts("NO");
	}
}


然后再是AC代码,比较下不同之处就在于return的地方还有flag地方不是很会用

还有奇偶剪枝的内容;

http://baike.baidu.com/link?url=ppGophm9_ZxsO1iVhmILiV8RTbSwmyJpcLX1mt0ip1RwLnpy5mmwLx4XmtXbDGrTA3FENrL2qgrE8AvXt8vZCq

可以参考一下这个人写的,挺不错的。

那么附上代码:

#include<stdio.h>
#include<math.h>
#include<string.h>
char map[10][10];
int book[10][10],n,m,end_x,end_y,t,flag;
void dfs(int x,int y,int step){
    int next[4][2]={0,1,1,0,0,-1,-1,0};
    int tx,ty;
    if(x==end_x && y==end_y && step==t){
        flag=1; return;
    }
    int dis;
    dis=(t-step)-(fabs(x-end_x)+fabs(y-end_y));
    if(dis<0||dis%2)  return;
    for(int i=0;i<4;i++){
        tx=x+next[i][0];
        ty=y+next[i][1];
        if(tx<0||ty<0||tx>n-1||ty>m-1||map[tx][ty]=='X'||book[tx][ty]==1)     continue;
        else{
            book[tx][ty]=1;
            dfs(tx,ty,step+1);
            if(flag)  return;
            book[tx][ty]=0;
        }
    }
    return;
}
int main(){
    int i,j,k;
    int startx,starty;
    while(~scanf("%d%d%d",&n,&m,&t)){
        if(n==0&&m==0&&t==0)  break;
        for(i=0;i<n;i++)
            scanf("%s",map[i]);
        memset(book,0,sizeof(book));
        for(i=0;i<n;i++){
            for(j=0;j<m;j++){
                if(map[i][j]=='S')  {startx=i; starty=j;}
                if(map[i][j]=='D')  {end_x=i; end_y=j;}
            }
        }
        book[startx][starty]=1;
        flag=0;
        dfs(startx,starty,0);
        if(flag)  puts("YES");
        else     puts("NO");
    }
}


 

这要注意一下dfs部分的内容就好了,加油!

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值