数据结构实验之链表三:链表的逆置

Problem Description
输入多个整数,以-1作为结束标志,顺序建立一个带头结点的单链表,之后对该单链表的数据进行逆置,并输出
逆置后的单链表数据。
Input
输入多个整数,以-1作为结束标志。
Output
输出逆置后的单链表数据。
Sample Input
12 56 4 6 55 15 33 62 -1
Sample Output
62 33 15 55 6 4 56 12
Hint
不得使用数组。
AC代码://今天无意间做了这道题,发现这个代码比之前的代码简单,关键是不用判断临界条件,防止越界。课本
//上的是带有判断的。

#include <iostream>
#include <cstdlib>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
struct node
{
    int data;
    struct node *next;
};
int main()
{
    int n;
    struct node *head,*p,*tail,*q;
    head = (struct node *)malloc(sizeof(struct node));
    head->next = NULL;
    tail = head;
    while(scanf("%d",&n)&&n!=-1)
    {
        p = (struct node *)malloc(sizeof(struct node));
        p->next = NULL;
        p->data = n;
        tail->next = p;
        tail = p;
    }
    //关键代码:
    tail = head->next;
    head->next = NULL;
    while(tail)
    {
        q = tail->next;
        tail->next = head->next;
        head->next = tail;
        tail = q;
    }
    p = head->next;
    while(p)
    {
        printf(p->next==NULL?"%d\n":"%d ",p->data);
        p=p->next;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值