HDU 2136 Largest prime factor (水)

Largest prime factor

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)


Problem Description
Everybody knows any number can be combined by the prime number.
Now, your task is telling me what position of the largest prime factor.
The position of prime 2 is 1, prime 3 is 2, and prime 5 is 3, etc.
Specially, LPF(1) = 0.
 

Input
Each line will contain one integer n(0 < n < 1000000).
 

Output
Output the LPF(n).
 

Sample Input
  
  
1 2 3 4 5
 

Sample Output
  
  
0 1 2 1 3


#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <utility>
#include <queue>
#define MAX 1000000
using namespace std;

int lpf[MAX];

int main(){
    int n,cnt,i,j;
    memset(lpf,0,sizeof(lpf));
    lpf[2]=1;
    for(i=4;i<MAX;i+=2)
        lpf[i]=lpf[2];
    cnt=2;
    for(i=3;i<MAX;i+=2){
        if(lpf[i])
            continue;
        lpf[i]=cnt++;
        for(j=(i<<1);j<MAX;j+=i)
            lpf[j]=lpf[i];
    }
    while(~scanf("%d",&n))
        printf("%d\n",lpf[n]);
    return 0;
}


类似筛素数的方法,先把lpf数组清0,然后题目要求lpf[1]=0,所以这个不用改,把lpf[2]置为1,因为他自己就是素数,所以他的lpf就是他自己,而2是第一个素数,所以。。

接下来为了提高一点点效率,我先把所有的偶数的lpf都置为2,用一个cnt记录是第几个素数,然后就跟筛素数一样,从3开始找lpf为0的数,有且仅有这些数是素数,把相应的cnt给lpf,然后开始找这些数i的倍数,更新这些倍数j的lpf[j]为lpf[i],因为他们都是i的倍数,而i是素数,他们当前的最大lpf肯定就是i(当然以后可能会更新),lpf[i]表示的就是素数i是第几个素数,所以lpf[j]=lpf[i]。就这样,打好表,然后输入一个n就输出表格的相应内容就行了。


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值