Prime Ring Problem
Time Limit : 4000/2000ms (Java/Other) Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 43 Accepted Submission(s) : 11
Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, …, n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.
Note: the number of first circle should always be 1.
Input
n (0 < n < 20).
Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order. You are to write a program that completes above process. Print a blank line after each case.
Sample Input
6
8
Sample Output
Case 1:
1 4 3 2 5 6
1 6 5 2 3 4
Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2
Source
Asia 1996, Shanghai (Mainland China)
Statistic | Submit | Back
#include <iostream>
#include <stdio.h>
#include <stdlib.h>
#include <cstring>
using namespace std;
int step[25]= {1,1},visit[25]= {0};
int n;
int prime(int x)
{
for(int i=2; i*i<=x; i++)
if(x%i==0)
return 0;
return 1;
}
void dfs(int x)
{
if(x==(n-1)&&prime(step[x]+1))
{
for(int i=0; i<n-1; i++)
printf("%d ",step[i]);
printf("%d\n",step[n-1]);
}
else
{
for(int i=2; i<=n; i++)
if(prime(i+step[x])!=0&&visit[i]==0)
{
step[x+1]=i;
visit[i]=1;
dfs(x+1);
visit[i]=0;
}
}
}
int main()
{
int cas=1;
memset(visit,0,sizeof(visit));
while(scanf("%d",&n)!=EOF)
{
printf("Case %d:\n",cas++);
visit[1]=1;
dfs(0);
printf("\n");
}
return 0;
}