POJ2229 Sumsets

Description

Farmer John commanded his cows to search for different sets of numbers that sum to a given number. The cows use only numbers that are an integer power of 2. Here are the possible sets of numbers that sum to 7:

1) 1+1+1+1+1+1+1
2) 1+1+1+1+1+2
3) 1+1+1+2+2
4) 1+1+1+4
5) 1+2+2+2
6) 1+2+4

Help FJ count all possible representations for a given integer N (1 <= N <= 1,000,000).

Input

A single line with a single integer, N.

Output

The number of ways to represent N as the indicated sum. Due to the potential huge size of this number, print only last 9 digits (in base 10 representation).

Sample Input

7

Sample Output

6

找规律做出
多写几组数据:
1 -> 1
2 -> 2
3 -> 2
4 -> 4
5 -> 4
6 -> 6
7 -> 6
就可以看出来当n为奇数,ans=sum[n-1],n为偶数时,ans=sum[n-1]+sum[n/2]

CODE

#include <stdio.h>
int sum[1000000];
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {

    sum[1]=1;
    sum[2]=2;
    for(int i=3;i<=n;i++)
    {
        if(i%2!=0)
            sum[i]=sum[i-1];
        else
            sum[i]=(sum[i-2]+sum[i/2])%1000000000;
    }
    printf("%d\n",sum[n]);
    }
}

看了题解后,这不是规律,这是有道理的!而且这题是可以用动态规划做的!

所谓找规律的道理所在:

设a[n]为和为 n 的种类数;
根据题目可知,加数为2的N次方,即 n 为奇数时等于它前一个数 n-1 的种类数 a[n-1] ,若 n 为偶数时分加数中有无 1 讨论,即关键是对 n 为偶数时进行讨论:
1.n为奇数,a[n]=a[n-1]
2.n为偶数:
(1)如果加数里含1,则一定至少有两个1,即对n-2的每一个加数式后面 +1+1,总类数为a[n-2];
(2)如果加数里没有1,即对n/2的每一个加数式乘以2,总类数为a[n/2];
所以总的种类数为:a[n]=a[n-2]+a[n/2];

动态规划思想:

附一个完全背包解法,暂时没有想出这个代码的含义

#include <iostream>
#include <cstdio>
#include <string.h>
#include <stack>
#include <queue>
#include <map>
#include <set>
#include <vector>
#include <math.h>
#include <algorithm>
using namespace std;
#define LL long long
#define INF 0x3f3f3f3f
const double pi = acos(-1.0);
const int mod = 1e9;

const int N =1e6+10;

int dp[N];

void Init()
{
    memset(dp,0,sizeof(dp));


    dp[0]=dp[1]=1;
    for(int i=1;i<=22;i++)
    {
        for(int j=2;j<=1000000;j++)
        {
            int v=1<<(i-1);
            if(j>=v)
                dp[j]=dp[j-v]+dp[j];
            while(dp[j]>mod)
                dp[j]-=mod;
        }
    }
}
int main()
{
    int n;
    Init();
    while(~scanf("%d",&n))
        printf("%d\n",dp[n]);
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值