Description
It is a little known fact that cows love apples. Farmer John has two apple trees (which are conveniently numbered 1 and 2) in his field, each full of apples. Bessie cannot reach the apples when they are on the tree, so she must wait for them to fall. However, she must catch them in the air since the apples bruise when they hit the ground (and no one wants to eat bruised apples). Bessie is a quick eater, so an apple she does catch is eaten in just a few seconds.
Each minute, one of the two apple trees drops an apple. Bessie, having much practice, can catch an apple if she is standing under a tree from which one falls. While Bessie can walk between the two trees quickly (in much less than a minute), she can stand under only one tree at any time. Moreover, cows do not get a lot of exercise, so she is not willing to walk back and forth between the trees endlessly (and thus misses some apples).
Apples fall (one each minute) for T (1 <= T <= 1,000) minutes. Bessie is willing to walk back and forth at most W (1 <= W <= 30) times. Given which tree will drop an apple each minute, determine the maximum number of apples which Bessie can catch. Bessie starts at tree 1.
Input
Line 1: Two space separated integers: T and W
Lines 2..T+1: 1 or 2: the tree that will drop an apple each minute.
Output
- Line 1: The maximum number of apples Bessie can catch without walking more than W times.
Sample Input
7 2
2
1
1
2
2
1
1
Sample Output
6
Hint
INPUT DETAILS:
Seven apples fall - one from tree 2, then two in a row from tree 1, then two in a row from tree 2, then two in a row from tree 1. Bessie is willing to walk from one tree to the other twice.
OUTPUT DETAILS:
Bessie can catch six apples by staying under tree 1 until the first two have dropped, then moving to tree 2 for the next two, then returning back to tree 1 for the final two.
题意:
有一头牛,两棵树,开始牛在1号树下,每秒钟两棵树中的某一棵会掉下一颗苹果,牛最多能在这两棵树间移动W次,求N秒钟内牛最多能接到多少颗苹果。
题解
这个牛是在第一个树下面开始的,这就简单了很多,我们可以直接求出此时牛在哪棵树下,也就是i%2+1(i是移动的次数)。。
dp[i][j]表示第i秒移动最多j步接到的最多苹果。
CODE
#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
using namespace std;
int dp[1001][31],f[1001];
int main()
{
int t,w;
while(scanf("%d %d",&t,&w)!=EOF)
{
for(int i=1;i<=t;i++)
scanf("%d",&f[i]);
memset(dp,0,sizeof(dp));
for(int i=1;i<=t;i++)
{
//单独算一下移动0次的,否则j-1会下标越界。
//如果刚好这棵树往下掉苹果,那么不用移动就可以得到这可苹果了
dp[i][0]=dp[i-1][0]+(f[i]==1);
//比较移动1-w次牛得到的苹果个数
//同上看这棵树是不是会掉苹果了,掉了就加1
for(int j=1;j<=w&&j<=i;j++)
dp[i][j]=max(dp[i-1][j],dp[i-1][j-1])+(j%2+1==f[i]);
}
sort(dp[t],dp[t]+w);
printf("%d\n",dp[t][w]);
}
return 0;
}