Poj3278 BFS Catch That Cow

Catch That Cow

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.
Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
Teleporting: FJ can move from any point X to the point 2 × X in a single minute.
If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input
Line 1: Two space-separated integers: N and K
Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Sample Input
5 17
Sample Output
4

BFS水题,本题最大的坑点在于对步数操作时,步数可能会超过标记数组的范围,因此在入队之前要判断一下值的大小,不能大于最大值,也不能小于0.

#include<cstdio>
#include<queue>
#include<cstring>
using namespace std;
typedef struct A
{
    int val;
    int mint;
}niu;

int a[1000010];
int main()
{
    queue<niu> q;
    int cow,obj,temp1;
    memset(a,0,sizeof(a));
    niu temp;
    scanf("%d%d",&cow,&obj);
    a[cow] = 1;
    temp.val = cow;
    temp.mint = 0;
    q.push(temp);
    while(q.front().val != obj && !q.empty())
    {
        temp1 = q.front().val-1;
        if(  temp1 >= 0 && temp1 <= 1000000 && a[temp1] == 0)//小技巧利用短路效应简化一下,a[temp1]放到后面
        {
            a[temp1] = 1;
            temp.val = temp1;
            temp.mint = q.front().mint+1;
            q.push(temp);
        }

        temp1 = q.front().val+1;
        if(temp1 >= 0 && temp1 <= 1000000 && a[temp1] == 0)
        {
            a[temp1] = 1;
            temp.val = temp1;
            temp.mint = q.front().mint+1;
            q.push(temp);
        }

        temp1 = (q.front().val)*2;
        if(temp1 >= 0 && temp1 <= 1000000 && a[temp1] == 0)
        {
            a[temp1] =1;
            temp.val = temp1;
            temp.mint = q.front().mint+1;
            q.push(temp);
        }

        q.pop();
    }

    printf("%d\n",q.front().mint);
    return 0;
}

**总结:在进行数组操作时,一定要注意下标的范围,保证不会RE。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值