给定任一个各位数字不完全相同的4位正整数,如果我们先把4个数字按非递增排序,再按非递减排序,然后用第1个数字减第2个数字,将得到一个新的数字。一直重复这样做,我们很快会停在有“数字黑洞”之称的6174。
例如,我们从6767开始,将得到
7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
7641 - 1467 = 6174
... ...
现给定任意4位正整数,请编写程序演示到达黑洞的过程。
输入格式:
输入给出一个(0, 10000)区间内的正整数N。
输出格式:
如果N的4位数字全相等,则在一行内输出“N - N = 0000”;否则将计算的每一步在一行内输出,直到6174作为差出现,输出格式见样例。注意每个数字按4位数格式输出。
输入样例1:6767输出样例1:
7766 - 6677 = 1089 9810 - 0189 = 9621 9621 - 1269 = 8352 8532 - 2358 = 6174输入样例2:
2222输出样例2:
2222 - 2222 = 0000
解:
public class Main {
public static void main(String[] args) {
Scanner out = new Scanner(System.in);
int x = out.nextInt();
int a = big(x) - small(x);
if (a == 0) {
System.out.printf("%04d - %04d = %04d\n", big(x), small(x), a);
} else {
int n;
do {
n = big(x) - small(x);
System.out.printf("%04d - %04d = %04d\n", big(x), small(x), n);
x = n;
} while (n != 6174);
}
}
public static int big(int x) {
int[] p = new int[4];
p[0] = x / 1000;
p[1] = x % 1000 / 100;
p[2] = x % 100 / 10;
p[3] = x % 10;
Arrays.sort(p);
int sum = p[3] * 1000 + p[2] * 100 + p[1] * 10 + p[0];
return sum;
}
public static int small(int x) {
int[] p = new int[4];
p[0] = x / 1000;
p[1] = x % 1000 / 100;
p[2] = x % 100 / 10;
p[3] = x % 10;
Arrays.sort(p);
int sum = p[0] * 1000 + p[1] * 100 + p[2] * 10 + p[3];
return sum;
}
}