[poj 3026] Borg Maze --bfs求最短距离+最小生成树

[poj 3026] Borg Maze –bfs求最短距离+最小生成树

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 17404Accepted: 5614

Description

The Borg is an immensely powerful race of enhanced humanoids from the delta quadrant of the galaxy. The Borg collective is the term used to describe the group consciousness of the Borg civilization. Each Borg individual is linked to the collective by a sophisticated subspace network that insures each member is given constant supervision and guidance.
Your task is to help the Borg (yes, really) by developing a program which helps the Borg to estimate the minimal cost of scanning a maze for the assimilation of aliens hiding in the maze, by moving in north, west, east, and south steps. The tricky thing is that the beginning of the search is conducted by a large group of over 100 individuals. Whenever an alien is assimilated, or at the beginning of the search, the group may split in two or more groups (but their consciousness is still collective.). The cost of searching a maze is definied as the total distance covered by all the groups involved in the search together. That is, if the original group walks five steps, then splits into two groups each walking three steps, the total distance is 11=5+3+3.

Input

On the first line of input there is one integer, N <= 50, giving the number of test cases in the input. Each test case starts with a line containg two integers x, y such that 1 <= x,y <= 50. After this, y lines follow, each which x characters. For each character, a space '' stands for an open space, a hash mark#” stands for an obstructing wall, the capital letter A'' stand for an alien, and the capital letterS” stands for the start of the search. The perimeter of the maze is always closed, i.e., there is no way to get out from the coordinate of the “S”. At most 100 aliens are present in the maze, and everyone is reachable.

Output

For every test case, output one line containing the minimal cost of a succesful search of the maze leaving no aliens alive.

Sample Input

2
6 5
##### 
#A#A##
# # A#
#S  ##
##### 
7 7
#####  
#AAA###
#    A#
# S ###
#     #
#AAA###
#####  

Sample Output

8
11

Source

Svenskt Mästerskap i Programmering/Norgesmesterskapet 2001

题意解析:

​ 给你一个迷宫,#是不能走的地方,求连通所有A或者S的最小距离,也就是最小生成树。

​ Whenever an alien is assimilated, or at the beginning of the search, the group may split in two or more groups (but their consciousness is still collective.). 这句话说明了只有到节点了才能选择别的路径,所以路径不能中途岔开,所以是最小生成树。

​ 因为是最小生成树,所以其实A和S是一样的。所以我们只要bfs求出任意两点之间的距离,然后prim就行了。
另外还有两个坑点,一个是输入完行列之后莫名有多余的空格,然后gets掉;另一个是我数组开到100没过,开到120就过了。

代码:

#include<iostream>
#include<algorithm>
#include<queue>
#include<cstdio>
#include<cstring>
using namespace std;

const int maxn = 120;
int a[maxn][maxn];//记录A或者S的位置
int map[maxn][maxn];//读入图
int dis[maxn][maxn];//记录点和点之间的距离
bool vis[maxn];//点是否被访问过
int t[maxn][maxn];//bfs记录步数
int mincost[maxn];//prim到已有顶点集的最小距离
int mov[][2] = { { 1,0 },{ -1,0 },{ 0,1 },{ 0,-1 } };//方向向量

void bfs(int sx, int sy){
    queue<pair<int, int> >q;
    while (!q.empty()) q.pop();
    memset(t, -1, sizeof(t));
    t[sx][sy] = 0;
    q.push(make_pair(sx, sy));
    while (!q.empty()){
        pair<int, int> now = q.front();
        q.pop();
        if (a[now.first][now.second] != -1)
            dis[a[sx][sy]][a[now.first][now.second]] = t[now.first][now.second];
        for (int i = 0; i<4; i++){
            int tx = now.first + mov[i][0];
            int ty = now.second + mov[i][1];
            if (map[tx][ty] == '#' || t[tx][ty] != -1)continue;
            t[tx][ty] = t[now.first][now.second] + 1;
            q.push(make_pair(tx, ty));
        }
    }
}
int prim(int n) {
    int ans = 0;
    for (int i = 0; i < n; i++) {
        vis[i] = false;
        mincost[i] = dis[0][i];
    }
    vis[0] = true;
    mincost[0] = 0;
    while (true) {
        int v = -1;
        for (int i = 0; i < n; i++) {
            if (!vis[i] && (v == -1 || mincost[i] < mincost[v])) v = i;
        }
        if (v == -1)break;
        ans += mincost[v];
        vis[v] = true;
        for (int i = 0; i < n; i++) {
            mincost[i] = min(mincost[i], dis[v][i]);
        }
    }
    return ans;
}
int main() {
    int t;
    scanf("%d", &t);
    while (t--) {
        int col, row;
        int cnt = 0;
        char op[maxn];
        memset(a, -1, sizeof(a));
        memset(dis, 0x3f, sizeof(dis));
        scanf("%d%d", &col, &row);
        gets(op);
        for (int i = 0; i < row; i++) {
            gets(op);
            for (int j = 0; j < col; j++) {
                map[i][j] = op[j];
                if (map[i][j] == 'A' || map[i][j] == 'S') {
                    a[i][j] = cnt++;
                }
            }
        }
        for (int i = 0; i < row; i++) {
            for (int j = 0; j < col; j++) {
                if (a[i][j] != -1)
                    bfs(i, j);
            }
        }
        printf("%d\n", prim(cnt));
    }
    return 0;
}

​ 最开始不知道怎么写bfs,参考了kuangbin大神的代码
地址:https://www.cnblogs.com/kuangbin/p/3147031.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值