LA2565 Extraterrestrial Intelligence

Calling Extraterrestrial Intelligence Again

Time limit: 3.000 seconds

A message from humans to extraterrestrial inteIigence was sent through the Arecibo radio telescope in Puerto Rico on the afternoon of Saturday November l6, l974. The message consisted of l679 bits and was meant to be translated to a rectangular picture with 23 x 73 pixels. Since both 23 and 73 are prime numbers, 23 x 73 is the unique possible size of the translated rectangular picture each edge of which is longer than l pixel. Of course, there was no guarantee that the receivers would try to translate the message to a rectangular picture. Even if they would, they might put the pixels into the rectangle incorrectly. The senders of the Arecibo message were optimistic.


We are planning a similar project. Your task in the project is to find the most suitable width and height of the translated rectangular picture. The term ``most suitable'' is defined as follows. An integer m greater than 4 is given. A positive fraction a/b less than or equal to 1 is also given. The area of the picture should not be greater than m . Both of the width and the height of the translated picture should be prime numbers. The ratio of the width to the height should not be less than a/b nor greater than 1. You should maximize the area of the picture under these constraints.


In other words, you will receive an integer m and a haction a/b . It holds that m > 4 and 0 < a/b$ \le$1 . You should find the pair of prime numbers pq such that pq$ \le$m and a/b$ \le$p/q$ \le$1 , and furthermore, the product pqtakes the maximum value among such pairs of two prime numbers. You should report p and q as the ``most suitable'' width and height of the translated picture.

The input is a sequence of at most 2000 triplets of positive integers, delimited by a space character in between. Each line contains a single triplet. The sequence is followed by a triplet of zeros, 0 0 0, which indicates the end of the input and should not be treated as data to be processed.

The integers of each input triplet are the integer m , the numerator a , and the denominator b described above, in this order. You may assume 4 < m$ \le$100000 and 1$ \le$a$ \le$b$ \le$1000 .

The output is a sequence of pairs of positive integers. The i -th output pair corresponds to the i -th input triplet. The integers of each output pair are the width p and the height q described above, in this order.

Each output line contains a single pair. A space character is put between the integers as a delimiter. No other characters should appear in the output.

Sample Input

5 1 2
99999 999 999
1680 5 16
1970 1 1
2002 4 11
0 0 0
Sample Output

2 2
313 313
23 73
43 43
37 53

這道題不難,本以為需要binary search質數表,但最後沒有用還是AC了。簡單而言此題就是告訴你m,a,b三個值,要滿足三個條件,即p*q<=m,0<a/b<=p/q<=1,p*q要最大。而m最大值為10萬,其實質數表建到5萬就夠了,因為p*q<=m,p至少為2,所以最大質數會在5萬以內。

#include <cstdio>
#include <math.h>
using namespace std;
int p[50000]; // to store all prime numbers, since m<=100000 and p*q<=m,so actually the size m/2 is enough
int find_prime()
{
    int i;
    int k = 1;
    p[0] = 2;  // first prime number
    for( i=3;i<50000;i++ )
    {
        int s = 0;
        for( int j=2;j<=sqrt(i);j++ )  // mod from 2 to sqrt(i) to check whether it is prime number 
        {
            if( i%j == 0 ) s = 1;
        }
        if( s == 0 )
        {
            p[k] = i;
            k++;
        } 
    }
    return k; // return index of array p
}
void ans( int m, int a, int b, int mm ) // mm is the index of p
{
    int pp, qq;
    int max = 0;
    for( int i=0;i<mm&&p[i]<=sqrt(m);i++) // since p*q<=m & p<=q, so max(p) = sqrt(m)
    {
        for( int j=i;j<mm;j++)  // q>=p
        {
            if( p[i]*b<p[j]*a ) break;
            if( p[i]*p[j]>m ) break;
            if( p[i]*p[j]>max )
            {
                max = p[i]*p[j];
                pp = p[i];
                qq = p[j];
            }
        }
    }
    printf("%d %d\n",pp,qq);
}
int main()
{
    int m, a, b;
    int mm = find_prime();
    while( scanf("%d%d%d",&m,&a,&b)!=EOF && (m+a+b)!=0 )
    {
        ans(m,a,b,mm);
    }
    return 0;
}

我這裡用的找質數的方法效率很低,即判斷一個數字i跟2~sqrt(i)每個數進行取餘數即判斷能否整除來決定是否為質數。但有更加高效的算法,以後我會補上討論。



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
Mars is the fourth planet in our solar system and is known as the "Red Planet" due to its reddish appearance. It is roughly half the size of Earth and has a thin atmosphere composed mainly of carbon dioxide. Mars has long been of interest to humans due to its potential for supporting life and its proximity to Earth. Space exploration is important for several reasons. Firstly, it allows us to learn more about the universe and how it works, which can help us understand our place in it. Secondly, it allows us to search for extraterrestrial life and to study planets like Mars for potential colonization or resource extraction. Thirdly, space exploration has a significant impact on technological advancement and innovation, leading to spin-off technologies that can benefit society in a variety of ways. Mars exploration, in particular, has received a great deal of attention in recent years due to its potential for supporting human life. Scientists believe that Mars once had a more Earth-like environment and may have supported microbial life in the past. Studying Mars can help us better understand the conditions necessary for life to exist and how we might create those conditions on other planets in the future. In addition, Mars has the potential to serve as a location for human settlement or resource extraction. Mars contains a variety of minerals and resources that could be valuable in future space exploration or even back on Earth. Colonizing Mars would also provide backup for human civilization in the event of a catastrophic event on Earth. Overall, space exploration, and Mars exploration in particular, are crucial for advancing our understanding of the universe and our place in it, discovering potential extraterrestrial life, and laying the foundation for future human settlement and resource extraction.

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值