PAT A1069/B1019 The Black Hole of Numbers /数字黑洞

数字问题-pat
题目:
     1069 The Black Hole of Numbers (20 分)
  For any 4-digit integer except the ones with all the digits being the same, if we sort the digits in non-increasing order first, and then in non-decreasing order, a new number can be obtained by taking the second number from the first one. Repeat in this manner we will soon end up at the number 6174 – the black hole of 4-digit numbers. This number is named Kaprekar Constant.

For example, start from 6767, we’ll get:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
7641 - 1467 = 6174
… …
Given any 4-digit number, you are supposed to illustrate the way it gets into the black hole.

Input Specification:
Each input file contains one test case which gives a positive integer N in the range (0,10^4).

Output Specification:
If all the 4 digits of N are the same, print in one line the equation N - N = 0000. Else print each step of calculation in a line until 6174 comes out as the difference. All the numbers must be printed as 4-digit numbers.

Sample Input 1:
6767
Sample Output 1:
7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174

Sample Input 2:
2222
Sample Output 2:
2222 - 2222 = 0000

官网链接:pat A1069

总结:

  1. 用sscanf和sprintf耗时太长,在这道题中会超时。因此,对一个数字进行排序的正确方法是:先把它转换为int数组,再对int数组进行排序
  2. 使用do while 后判断循环,保证input是6174时仍可以展示过程。
  3. C++不能返回数组,因此总是将数组的首地址作为function参数,通过function处理数组。
  4. 输出时总是记得带上‘\n’。

代码:

//正确答案
#include<stdio.h>
#include<algorithm>
using namespace std;
int changeNumArrayToNum(int num_array[]){
	int num = 0;
	for(int i = 0; i < 4; i++){
		num = num*10 + num_array[i];
	}
	return num;
}

//C++不能返回数组 
void changeNumToNumArray(int num, int num_array[]){
	for(int i = 3; i >=0 ; i--){
		num_array[i] = num % 10;
		num /= 10;
	}
}

bool cmp(int a, int b){
	return a > b;
}
int main(){
	int num, min, max;
	scanf("%d", &num);
	int num_array[4];
	do{
	//给num_array[4]赋值 
	changeNumToNumArray(num, num_array);
	
	//min 递增
	sort(num_array, num_array+4);
	min = changeNumArrayToNum(num_array);
	
	//max 递减
	sort(num_array, num_array+4, cmp);
	max = changeNumArrayToNum(num_array); 
	
	num = max- min;
	printf("%04d - %04d = %04d\n", max, min, num);
	}while(num != 0 && num != 6174);
	
}
//超时答案
//超时写法,猜测是sscanf和sprintf速度慢 
#include<stdio.h>
#include<algorithm>
using namespace std;

bool cmp(char a, char b){
    return a > b;
}

int main(){
    int num, min, max, times = 0;
    char str[5];
    scanf("%d", &num);
    //使用do-while保证6174输入后有输出 
    do{
        sprintf(str, "%d", num);
               
        //递减->max
        sort(str, str+4, cmp);
        sscanf(str, "%d", &max);
        
        //递增->min
        sort(str, str+4);    
        sscanf(str, "%d", &min);
        num = max - min;
        printf("%04d - %04d = %04d\n", max, min, num);
    }while(num != 0 && num != 6174);
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值