PAT(甲级)1143. Lowest Common Ancestor(30)

PAT 1143. Lowest Common Ancestor(30)
The lowest common ancestor (LCA) of two nodes U and V in a tree is the deepest node that has both U and V as descendants.
A binary search tree (BST) is recursively defined as a binary tree which has the following properties:
1.The left subtree of a node contains only nodes with keys less than the node’s key.
2.The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
3.Both the left and right subtrees must also be binary search trees.
Given any two nodes in a BST, you are supposed to find their LCA.


输入格式:
Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 1,000), the number of pairs of nodes to be tested; and N (≤ 10,000), the number of keys in the BST, respectively. In the second line, N distinct integers are given as the preorder traversal sequence of the BST. Then M lines follow, each contains a pair of integer keys U and V. All the keys are in the range of int.

输出格式:
For each given pair of U and V, print in a line LCA of U and V is A. if the LCA is found and A is the key. But if A is one of U and V, print X is an ancestor of Y. where X is A and Y is the other node. If U or V is not found in the BST, print in a line ERROR: U is not found.or ERROR: V is not found. or ERROR: U and V are not found..

输入样例:

6 8
6 3 1 2 5 4 8 7
2 5
8 7
1 9
12 -3
0 8
99 99

输出样例:

LCA of 2 and 5 is 3.
8 is an ancestor of 7.
ERROR: 9 is not found.
ERROR: 12 and -3 are not found.
ERROR: 0 is not found.
ERROR: 99 and 99 are not found.

题目分析:题目给出的是BST树,可以利用BST的中序遍历是顺序序列这一性质。由前序序列排序后获得中序序列,使用中序序列和前序序列重构二叉树即可。

AC代码:

#include <iostream>
#include <algorithm>
#include <map>
using namespace std;

const int maxn = 10010;
map<int, bool> mp;
int in[maxn];
int pre[maxn];
int post[maxn];
int preTemp[maxn];


struct node{
    int data;
    node* lchild;
    node* rchild;
};


node* build(int preL, int preR, int inL, int inR){
    if(preL>preR)return NULL;
    node* root = new node;
    root->data = pre[preL];
    int k;
    for(k=inL; k<=inR; ++k){
        if(in[k] == pre[preL])break;
    }
    int leftnum = k-inL;
    root->lchild = build(preL+1, preL+leftnum, inL, k-1);
    root->rchild = build(preL+leftnum+1, preR, k+1, inR);
    return root;
}

void postorder(node* root){
    if(root){
        postorder(root->lchild);
        postorder(root->rchild);
        cout<<root->data<<" ";
    }
}


node* lca(node* root, int u, int v){
    if(root==NULL)return NULL;
    if(root->data==u || root->data==v)return root;

    node* left = lca(root->lchild, u, v);
    node* right = lca(root->rchild, u, v);
    if(left && right)return root;
    return left==NULL?right:left;
}

int main(){
    int m, n, u, v;
    scanf("%d%d",&m,&n);
    for(int i=0; i<n; ++i){
        scanf("%d", &pre[i]);
        mp[pre[i]] = true;
        preTemp[i] = pre[i];
    }
    sort(preTemp,preTemp+n);
    for(int i=0; i<n; ++i){in[i]=preTemp[i];}
    node* root = build(0, n-1, 0, n-1);
    for(int i=0; i<m; ++i){
        scanf("%d%d",&u,&v);
        if(mp[u]==false && mp[v]==false)
            printf("ERROR: %d and %d are not found.\n", u, v);
        else if(mp[u]==false || mp[v]==false){
            if(mp[u]==false)
                printf("ERROR: %d is not found.\n",u);
            else
                printf("ERROR: %d is not found.\n",v);
        }
        else{
            node* tmp = lca(root, u, v);
            if(tmp->data==u || tmp->data==v){
                if(tmp->data == u)
                    printf("%d is an ancestor of %d.\n", u, v);
                else
                    printf("%d is an ancestor of %d.\n", v, u);
            }
            else{
                printf("LCA of %d and %d is %d.\n", u, v, tmp->data);
            }
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值