PAT(甲级)1137.Fianl Grading(25)

PAT 1137.Fianl Grading(25)
For a student taking the online course “Data Structures” on China University MOOC (http://www.icourse163.org/), to be qualified for a certificate, he/she must first obtain no less than 200 points from the online programming assignments, and then receive a final grade no less than 60 out of 100. The final grade is calculated by G=(G
​mid−term×40%+G​final×60%) if G​mid−term>G​final, or G​final will be taken as the final grade G. Here G​mid−term​​ and G​final are the student’s scores of the mid-term and the final exams, respectively.
The problem is that different exams have different grading sheets. Your job is to write a program to merge all the grading sheets into one.

输入格式:
Each input file contains one test case. For each case, the first line gives three positive integers: P , the number of students having done the online programming assignments; M, the number of students on the mid-term list; and N, the number of students on the final exam list. All the numbers are no more than 10,000.Then three blocks follow. The first block contains P online programming scores G​p 's; the second one contains M mid-term scores Gmid−term’s; and the last one contains N final exam scores G​final​​ 's. Each score occupies a line with the format: StudentID Score, where StudentID is a string of no more than 20 English letters and digits, and Score is a nonnegative integer (the maximum score of the online programming is 900, and that of the mid-term and final exams is 100).

输出格式:
For each case, print the list of students who are qualified for certificates. Each student occupies a line with the format:
StudentID G​p Gmid−term G​final ​G If some score does not exist, output “−1” instead. The output must be sorted in descending order of their final grades (G must be rounded up to an integer). If there is a tie, output in ascending order of their StudentID's. It is guaranteed that the StudentID's are all distinct, and there is at least one qullified student.

输入样例:

6 6 7
01234 880
a1903 199
ydjh2 200
wehu8 300
dx86w 220
missing 400
ydhfu77 99
wehu8 55
ydjh2 98
dx86w 88
a1903 86
01234 39
ydhfu77 88
a1903 66
01234 58
wehu8 84
ydjh2 82
missing 99
dx86w 81

输出样例:

missing 400 -1 99 99
ydjh2 200 98 82 88
dx86w 220 88 81 84
wehu8 300 55 84 84

题目分析:乙级1080.mooc最终成绩

AC代码:

#include <bits/stdc++.h>
using namespace std;

struct Stu{
    string name;
    int gp, gmid, gfinal, G;
    Stu(string name, int gp, int gmid, int gfinal, int G){
        this->name = name;
        this->gp = gp;
        this->gmid = gmid;
        this->gfinal = gfinal;
        this->G = G;
    }
};


bool cmp(Stu a, Stu b){
    if(a.G != b.G)
        return a.G > b.G;
    else
        return a.name < b.name;
}

set<string> st;
vector<Stu> vec;
unordered_map<string, int> gp;
unordered_map<string, int> gmid;
unordered_map<string, int> gfinal;


int main(){
    string id;
    int p, m, n, score;
    scanf("%d%d%d", &p, &m, &n);
    for(int i=0; i<p; ++i){
        cin>>id;
        st.insert(id);
        scanf("%d", &score);
        gp[id] = score;
    }
    for(int i=0; i<m; ++i){
        cin>>id;
        st.insert(id);
        scanf("%d", &score);
        gmid[id] = score;
    }
    for(int i=0; i<n; ++i){
        cin>>id;
        st.insert(id);
        scanf("%d", &score);
        gfinal[id] = score;
    }

    int Gp, Gmid, Gfinal;
    for(auto it=st.begin(); it!=st.end(); ++it){
        if(gp.find(*it)!=gp.end())
            Gp = gp[*it];
        else
            Gp = -1;

        if(gmid.find(*it)!=gmid.end())
            Gmid = gmid[*it];
        else
            Gmid = -1;

        if(gfinal.find(*it)!=gfinal.end())
            Gfinal = gfinal[*it];
        else
            Gfinal = -1;

        double G;
        if(Gmid > Gfinal)
            G = (int)(Gmid*0.4 + Gfinal*0.6 + 0.5);
        else
            G  = Gfinal;

        if(Gp>=200 && G>=60)
            vec.push_back(Stu(*it, Gp, Gmid, Gfinal, G));
    }

    sort(vec.begin(), vec.end(), cmp);

    for(int i=0; i<vec.size(); ++i){
        cout<<vec[i].name;
        printf(" %d %d %d %d\n", vec[i].gp, vec[i].gmid, vec[i].gfinal, vec[i].G);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值