POJ 2506 Tiling 递推+大数

n how many ways can you tile a 2xn rectangle by 2x1 or 2x2 tiles?
Here is a sample tiling of a 2x17 rectangle.

Input

Input is a sequence of lines, each line containing an integer number 0 <= n <= 250.

Output

For each line of input, output one integer number in a separate line giving the number of possible tilings of a 2xn rectangle.

Sample Input

2
8
12
100
200

Sample Output

3
171
2731
845100400152152934331135470251
1071292029505993517027974728227441735014801995855195223534251


题意 :有一个2*n的大长方体;只用1*2,2*2两种长方体有多少种方法构成这个大长方体

代码:

import java.math.BigInteger;
import java.util.Scanner;;
public class Main {
	public static void main(String[] args) 
	{
		Scanner cin=new Scanner(System.in);
		BigInteger[] q=new BigInteger[255];             //大数数组的 定义
		q[0]=BigInteger.ONE;                            //大数数组的元素赋值 q[0]=1
		q[1]=BigInteger.ONE;                            
		q[2]=q[0].add(q[0].add(q[1]));                  //大数的加减乘除都是函数形式
		for(int i=3;i<=250;i++)
			q[i]=q[i-1].add(q[i-2].add(q[i-2]));
		int t;
		while(cin.hasNext())                    //多重输入
		{
			t=cin.nextInt();
			System.out.println(q[t]);
		}
		cin.close();                //多重输入要关闭文件
	}
}

简单的递推题 但加上了大数。。  

再次证明了JAVA对大数问题的简单实用

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值