POJ 1094 Sorting It All Out 拓扑排序

Description

An ascending sorted sequence of distinct values is one in which some form of a less-than operator is used to order the elements from smallest to largest. For example, the sorted sequence A, B, C, D implies that A < B, B < C and C < D. in this problem, we will give you a set of relations of the form A < B and ask you to determine whether a sorted order has been specified or not.

Input

Input consists of multiple problem instances. Each instance starts with a line containing two positive integers n and m. the first value indicated the number of objects to sort, where 2 <= n <= 26. The objects to be sorted will be the first n characters of the uppercase alphabet. The second value m indicates the number of relations of the form A < B which will be given in this problem instance. Next will be m lines, each containing one such relation consisting of three characters: an uppercase letter, the character "<" and a second uppercase letter. No letter will be outside the range of the first n letters of the alphabet. Values of n = m = 0 indicate end of input.

Output

For each problem instance, output consists of one line. This line should be one of the following three:

Sorted sequence determined after xxx relations: yyy...y.
Sorted sequence cannot be determined.
Inconsistency found after xxx relations.

where xxx is the number of relations processed at the time either a sorted sequence is determined or an inconsistency is found, whichever comes first, and yyy...y is the sorted, ascending sequence.

Sample Input

4 6
A<B
A<C
B<C
C<D
B<D
A<B
3 2
A<B
B<A
26 1
A<Z
0 0

Sample Output

Sorted sequence determined after 4 relations: ABCD.
Inconsistency found after 2 relations.
Sorted sequence cannot be determined.

题意:
每组数据给出N个元素 M组关系   可能推出三种结果:
1  Sorted sequence determined after 4 relations: ABCD.
 经过前四组关系 得出完整排序:ABCD
2   Inconsistency found after 2 relations.
 经过前2组关系 得出构成矛盾 (环)
3 Sorted sequence cannot be determined.
无法判断




代码:
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int map[28][28];
int pre[28];         //前驱节点
char str[100][5];    //保存每一句话
int que[28];         //保存拓扑排序的顺序
int m,n;
int tt;
int ss;
int topsort()
{
    int pree[28];
    int i,j,s;
    int ss=1;             //每次从1开始
    int loc;
    tt=1;                //假设构成拓扑排序
    for(i=1; i<=m; i++)
        pree[i]=pre[i];
    for(i=1; i<=m; i++)
    {
        s=0;
        for(j=1; j<=m; j++)          
        {
            if(pree[j]==0)
                s++,loc=j;
        }
        if(s==0)         //全部没有前驱节点
            return -1;      //判断得环
        if(s>1)          //同时有多个前驱为0
            tt=0;
            que[ss++]=loc;       //保存排序顺序
            pree[loc]=-1;
            for(j=1; j<=m; j++)
            {
                if(map[loc][j]==1)
                    pree[j]--;
            }
    }
    return tt;
}
int main()
{
    int i,j,num;
    while(scanf("%d%d",&m,&n)&&m+n)
    {
        memset(map,0,sizeof(map));
        memset(pre,0,sizeof(pre));
        for(i=1; i<=n; i++)
        {
            cin>>str[i];
        }
        for(i=1; i<=n; i++)
        {
            int a,b;
            a=str[i][0]-'A'+1;
            b=str[i][2]-'A'+1;
            map[a][b]=1;
            pre[b]++;
            tt=topsort();
            if(tt==-1||tt==1)
            {
                num=i;
                break;
            }
        }
        if(tt==-1)
            printf("Inconsistency found after %d relations.\n",num);
        else if(tt==1)
        {
            printf("Sorted sequence determined after %d relations: ",num);
            for(i=1;i<=m;i++)
            {
                printf("%c",que[i]+'A'-1);
            }
            printf(".\n");
        }
        else
            printf("Sorted sequence cannot be determined.\n");
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值