Secret Research ——字符串

  Secret Research 

At a certain laboratory results of secret research are thoroughly encrypted. A result of a single experiment is stored as an information of its completion:


`positive result', `negative result', `experiment failed' or `experiment not completed'


The encrypted result constitutes a string of digits S, which may take one of the following forms:

$\bullet$ positive result 		 S = 1 or S = 4 or S = 78 $\bullet$ negative result 		 S = S35 $\bullet$ experiment failed 		 S = 9S4 $\bullet$ experiment not completed 		 S = 190S 

(A sample result S35 means that if we add digits 35 from the right hand side to a digit sequence then we shall get the digit sequence corresponding to a failed experiment)


You are to write a program which decrypts given sequences of digits.

Input 

A integer  n  stating the number of encrypted results and then consecutive  n  lines, each containing a sequence of digits given as ASCII strings.

Output 

For each analysed sequence of digits the following lines should be sent to output (in separate lines):

+ for a positive result - for a negative result * for a failed experiment ? for a not completed experiment 

In case the analysed string does not determine the experiment result, a first match from the above list should be outputted.

Sample Input 

4
78
7835
19078
944

Sample Output 

+
-
?
*
读了大半天题目,到最后竟然是个水题!!!!
本题目一共四种输出情况,+,-,*,?,分别有他们对应的数字,只要一一对应起来就好了,不过要注意先判断‘-’再判断‘?’。
#include <iostream>
#include <stdio.h>
#include <string.h>

using namespace std;

int main()
{
    int n,l;
    char sz[10000];
    scanf("%d",&n);
    while(n--)
    {
        scanf("%s",sz);
        l = strlen(sz);
        if(strcmp(sz,"1") == 0 || strcmp(sz,"4") == 0 || strcmp(sz,"78") == 0)
            printf("+\n");
        else if(sz[l-1] == '5' && sz[l-2] == '3')
            printf("-\n");
        else if(sz[0] == '9' && sz[l-1] == '4')
            printf("*\n");
        else if(sz[0] == '1' && sz[1] == '9' && sz[2] == '0')
            printf("?\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值