The ? 1 ? 2 ? ... ? n = k problem ——求和规律

 The ? 1 ? 2 ? ... ? n = k problem 

The problem

Given the following formula, one can set operators '+' or '-' instead of each '?', in order to obtain a given k
? 1 ? 2 ? ... ? n = k

For example: to obtain k = 12 , the expression to be used will be:
- 1 + 2 + 3 + 4 + 5 + 6 - 7 = 12
with n = 7

The Input

The first line is the number of test cases, followed by a blank line.

Each test case of the input contains integer k (0<=|k|<=1000000000).

Each test case will be separated by a single line.

The Output

For each test case, your program should print the minimal possible n (1<=n) to obtain k with the above formula.

Print a blank line between the outputs for two consecutive test cases.

Sample Input

2

12

-3646397

Sample Output

7

2701

Alex Gevak
September 15, 2000 (Revised 4-10-00, Antonio Sanchez)



题意:给出最后的结果,在1,2,3,4,。。。。n的前面添加+或者-,使得式子运算结果等于给出的结果
解析:如果给定的结果是一个正数,那么我们需要找到一个前N项和大于给定结果的n,然后在此基础上添加减号。这里需要注意的是,在一个数前面添加一个减号,就相当于在总和里减去这个数的2倍,所以总和和给定的结果之间的差值一定要是偶数才可以,如果不是偶数,则无从添加减号。所以找到的n不是最小的,需要继续添加。

#include <stdio.h>
#include <string.h>
#include <algorithm>

using namespace std;

int main()
{
    int i,j,n,t;
    long long k,sum;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%lld",&k);
        if(k < 0)
            k = -k;
        for(i = 1;i < 100000;i++)
        {
            if(i * (i + 1) >= 2 * k)
                break;
        }
        sum = (i * (i + 1))/2;
        while((sum - k)%2 != 0)
        {
            i++;
            sum += i;
        }
        if(t > 0)
        printf("%d\n\n",i);
        else
            printf("%d\n",i);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值