Is It A Tree?——判断是否是一棵树(POJ)

Is It A Tree?
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 23262 Accepted: 7980

Description

A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties. 

There is exactly one node, called the root, to which no directed edges point. 
Every node except the root has exactly one edge pointing to it. 
There is a unique sequence of directed edges from the root to each node. 
For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not. 

In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.

Input

The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.

Output

For each test case display the line "Case k is a tree." or the line "Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1).

Sample Input

6 8  5 3  5 2  6 4
5 6  0 0

8 1  7 3  6 2  8 9  7 5
7 4  7 8  7 6  0 0

3 8  6 8  6 4
5 3  5 6  5 2  0 0
-1 -1

Sample Output

Case 1 is a tree.
Case 2 is a tree.

Case 3 is not a tree.

题意:根据题目中的规定判断能不能构成一棵树,需要注意的是没有节点也是一棵树(空树),如果只有一个结点,根据题目中的要求,一个节点不能指向自己,所以不能称之为树,一个节点不能指向自己的父节点或是祖先节点,同一条边重复不可以。。。。。。

不能构成树的测试数据:

1: 0 0 空树是一棵树
2: 1 1 0 0 不是树 不能自己指向自己
3: 1 2 1 2 0 0 不是树....
4: 1 2 2 3 4 5 不是树  森林不算是树(主要是注意自己)
5: 1 2 2 3 3 4 4 5 5 6 6 7 7 8 8 9 9 1  注意 一个节点在指向自己的父亲或祖先 都是错误的 即 9-->1 错
6: 1 2 2 1 0 0 也是错误的

开始想得太复杂了,用了并查集又用了入度检测,其实只需要对每个节点的入度进行检测就可以了,在这一棵树中,只有一个节点入度为0,其余节点的入度必须是1.而且,结点并不是从1开始的,也不是连续的,要注意记录在树中的节点编号。

#include <stdio.h>
#include <string.h>
#include <math.h>
#include <stdlib.h>
#include <algorithm>

using namespace std;
int id[10000],n,m,bj[10000];

int main()
{
    int Max = 0,k = 0;
    while(~scanf("%d%d",&n,&m))
    {
        k++;
        memset(id,0,sizeof(id));
        memset(bj,0,sizeof(bj));
        if(n == -1 && m == -1)
            break;
        if(n == 0 && m == 0)
        {
            printf("Case %d is a tree.\n",k);
            continue;
        }
        while(n != 0 && m != 0)
        {
            if(Max < n)
                Max = n;
            if(Max < m)
                Max = m;
            id[m]++;
            bj[n] = bj[m] = 1;
            scanf("%d%d",&n,&m);
        }
        int num = 0;
        for(int i = 1; i <= Max; i++)
        {
            if(id[i] == 0 && bj[i])
                num++;
            else if(id[i] != 1 && bj[i])
            {
                num = 9;
                break;
            }
        }
        if(num == 1)
        {
            printf("Case %d is a tree.\n",k);
        }
        else
        {
            printf("Case %d is not a tree.\n",k);
        }
    }
    return 0;
}<span style="font-family: 'Courier New', Courier, monospace;">                                                                                                                                                                                                                                         </span>

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值