题目描述
在一个字符串中找出元音字母a,e,i,o,u出现的次数。(注意,只统计小写元音字母)
输入
输入一行字符串(字符串中可能有空格,请用gets(s)方法把一行字符串输入到字符数组s中),字符串长度小于200个字符。
输出
输出一行,依次输出a,e,i,o,u在输入字符串中出现的次数,整数之间用空格分隔。
样例输入
If so, you already have a Google Account. You can sign in on the right.
样例输出
5 4 3 7 3
#include<stdio.h>
#include<string.h>
void main()
{
char s[200];
int n,a=0,e=0,i=0,o=0,u=0,k;
gets(s);
n=strlen(s);
for(k=0;k<n;k++)
{
if(s[k]=='a')
a++;
else if(s[k]=='e')
e++;
else if(s[k]=='i')
i++;
else if(s[k]=='o')
o++;
else if(s[k]=='u')
u++;
}
printf("%d %d %d %d %d\n",a,e,i,o,u);
}