HDOJ 5773 The All-purpose Zero

The All-purpose Zero

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1541    Accepted Submission(s): 739


Problem Description
?? gets an sequence S with n intergers(0 < n <= 100000,0<= S[i] <= 1000000).?? has a magic so that he can change 0 to any interger(He does not need to change all 0 to the same interger).?? wants you to help him to find out the length of the longest increasing (strictly) subsequence he can get.
 

Input
The first line contains an interger T,denoting the number of the test cases.(T <= 10)
For each case,the first line contains an interger n,which is the length of the array s.
The next line contains n intergers separated by a single space, denote each number in S.
 

Output
For each test case, output one line containing “Case #x: y”(without quotes), where x is the test case number(starting from 1) and y is the length of the longest increasing subsequence he can get.
 

Sample Input
  
  
2 7 2 0 2 1 2 0 5 6 1 2 3 3 0 0
 

Sample Output
  
  
Case #1: 5 Case #2: 5
Hint
In the first case,you can change the second 0 to 3.So the longest increasing subsequence is 0 1 2 3 5.
 

Author
FZU
 

Source
 

Recommend
wange2014
 

这个题在处理0的手法上和这个题: HDOJ 5256 序列变换处理数字的手法上有异曲同工之妙啊。

假设所有的0都被利用,所以不记录0,然后减去前面所有0的数目(因为如果0改变成了数字,那么那个数字最少会是LCS中前面的一个一个数字+1,在这个假设下,处理数字),最后求这个被处理过的序列的LCS。


#include<stdio.h>
#include<string.h>
#include<vector>
#include<algorithm>
using namespace std;
#define INF 0x3f3f3f3f
#define N 100000+10

int a[N];
int dp[N];
int main()
{
	int T,kcase=1;
	int i,j,n,x;
	scanf("%d",&T);
	while(T--)
	{
		memset(dp,0,sizeof(dp));
		dp[0]=-99999999;//注意这个要赋最小值,不然第一个值是-10的情况下不赋值就该WA了。憋问我为什么知道TAT
		scanf("%d",&n);
		int tmp=0;
		for(i=0,j=0;i<n;i++)
		{
			scanf("%d",&x);
			if(x==0)
			{
				tmp++;
				continue;
			}
			a[j++]=x-tmp;
		}
		int len=0;
		for(i=0;i<j;i++)
		{
			if(a[i]>dp[len])
			{
				dp[++len]=a[i];
				continue;
			}
			int k=lower_bound(dp+1,dp+len+1,a[i])-dp;
			dp[k]=a[i];
		}
		printf("Case #%d: %d\n",kcase++,len+tmp);
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值