HDOJ 1394 Minimum Inversion Number【求逆序数】

Minimum Inversion Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 18008    Accepted Submission(s): 10945


Problem Description
The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.

For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:

a1, a2, ..., an-1, an (where m = 0 - the initial seqence)
a2, a3, ..., an, a1 (where m = 1)
a3, a4, ..., an, a1, a2 (where m = 2)
...
an, a1, a2, ..., an-1 (where m = n-1)

You are asked to write a program to find the minimum inversion number out of the above sequences.
 

Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.
 

Output
For each case, output the minimum inversion number on a single line.
 

Sample Input
  
  
10 1 3 6 9 0 8 5 7 4 2
 

Sample Output
  
  
16
 

Author
CHEN, Gaoli
 

Source
 

Recommend
Ignatius.L
 

= =写了这个题我才发现求逆序数的时候不离散化的求法和离散化之后的求法还不太一样! (好烦QAQ)

这个题的大意不是很难理解,就是说给你一个序列,然后求逆序数。求完之后把这个序列第一个数放最后,再求逆序数。如此循环一圈,问这一圈里能得出的最小逆序数是多少?

这个题还有一点需要注意一下,就是把最前面的数放到最后面后怎么求逆序数,一遍一遍的跑肯定是不行的。具体用什么方法,可以直接看代码,然后这里有一份详解(点我!)写得很清楚,看不明白代码可以看这个。


#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define N 5000+10
int c[N],a[N];
int n;
int lowbit(int x)
{
	return x&(-x);
}
void add(int x)
{
	while(x<=n)
	{
		c[x]++;
		x+=lowbit(x);
	}
}
int gsum(int x)
{
	int s=0;
	while(x>0)
	{
		s+=c[x];
		x-=lowbit(x);
	}
	return s;
}

int main()
{
	int i;
	while(~scanf("%d",&n))
	{
		memset(c,0,sizeof(c));
		int ans=0;
		for(i=0;i<n;i++)
		{
			scanf("%d",&a[i]);
			a[i]++;
			ans+=gsum(n)-gsum(a[i]);
			add(a[i]);
		}
		int minn=ans;
		for(i=0;i<n;i++)  
        {  
            ans+=(n-a[i])-(a[i]-1);
            if(ans<minn) minn=ans;  
        }  
		printf("%d\n",minn);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值