13:K-based Numbers

Description

Let’sconsider K-basednumbers, containing exactly Ndigits. We define a number to be valid if its K-basednotation doesn’t contain two successive zeros. For example:

  • 1010230 is a valid 7-digitnumber;

  • 1000198 is not a validnumber;

  • 0001235 is not a 7-digitnumber, it is a 4-digit number.

Giventwo numbers Nand K,you are to calculate an amount of valid Kbased numbers, containing Ndigits.

Youmay assume that 2 ≤ K≤ 10; N≥ 2; N+ K≤ 18.

Input

Thenumbers Nand Kin decimal notation separated by the line break.

Output

The result in decimalnotation.

SampleInput

2

10

SampleOutput

90


package OJ;
import java.util.*;

public class P13_temp {

	public static void main(String[] args) {
		Scanner in = new Scanner(System.in);
		int digit = in.nextInt();
		int decimal = in.nextInt();
		int secdecimal = decimal - 1;
		int final_0 = 0;
		int Notfinal_0 = 0;
		int sum = 0;
		for(int i=0; i<digit; i++){
			if(i == 0){
				Notfinal_0 = secdecimal;
				sum = secdecimal;
			}			
			else{
				sum = final_0 * secdecimal + Notfinal_0 * decimal;
				if(i != digit-1){
					final_0 = Notfinal_0;
					Notfinal_0 = sum - final_0;
				}
			}
		}
		System.out.println(sum);
	}

}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值