P3131 [USACO16JAN] Subsequences Summing to Sevens S

分析了一种关于牛群ID的编程题目,通过前缀和和优化策略解决求最长连续子序列和为7的倍数的区间长度问题,最终给出了高效算法
摘要由CSDN通过智能技术生成

[USACO16JAN] Subsequences Summing to Sevens S

题目描述

Farmer John’s N N N cows are standing in a row, as they have a tendency to do from time to time. Each cow is labeled with a distinct integer ID number so FJ can tell them apart. FJ would like to take a photo of a contiguous group of cows but, due to a traumatic childhood incident involving the numbers 1 … 6 1 \ldots 6 16, he only wants to take a picture of a group of cows if their IDs add up to a multiple of 7.

Please help FJ determine the size of the largest group he can photograph.

给你n个数,分别是a[1],a[2],…,a[n]。求一个最长的区间[x,y],使得区间中的数(a[x],a[x+1],a[x+2],…,a[y-1],a[y])的和能被7整除。输出区间长度。若没有符合要求的区间,输出0。

输入格式

The first line of input contains N N N ( 1 ≤ N ≤ 50 , 000 1 \leq N \leq 50,000 1N50,000). The next N N N

lines each contain the N N N integer IDs of the cows (all are in the range

0 … 1 , 000 , 000 0 \ldots 1,000,000 01,000,000).

输出格式

Please output the number of cows in the largest consecutive group whose IDs sum

to a multiple of 7. If no such group exists, output 0.

样例

样例输入

7
3
5
1
6
2
14
10

样例输出

5

提示

In this example, 5+1+6+2+14 = 28.

想法(一阶段)

这题标签中带着前缀和,果断采用前缀和做法,开一个sum数组存前 i 项的和,后两个sum的差能被7整除,则它们的下标就是连续个数,取最大即可(见代码一)

代码一(70分)

#include <bits/stdc++.h>
#define int long long
#define endl '\n'
using namespace std;
int n, i, a[50005], sum[50005], cnt, j;
signed main() {
    ios::sync_with_stdio(0);
    cin.tie(0);
    cout.tie(0);
    cin >> n;
    for (i = 1; i <= n; i++) {
        cin >> a[i];
        sum[i] = sum[i - 1] + a[i];
    }
    for (i = 1; i <= n; i++) {
        for (j = 0; j < i; j++) {
            if ((sum[i] - sum[j]) % 7 == 0)    cnt = max(cnt, i - j);
        }
    }
    if (cnt == 0)  cout << "0";
    else cout << cnt;
    return 0;
}

想法(二阶段)

卡了几个点,考虑是否还能优化,没必要使用max去算,直接在 j 的循环中只看更大的可能性,于是有了代码二

代码二(80分)

#include <bits/stdc++.h>
#define int long long
#define endl '\n'
using namespace std;
int n, i, a[50005], sum[50005], cnt, j;
signed main() {
    ios::sync_with_stdio(0);
    cin.tie(0);
    cout.tie(0);
    cin >> n;
    for (i = 1; i <= n; i++) {
        cin >> a[i];
        sum[i] = sum[i - 1] + a[i];
    }
    for (i = 1; i <= n; i++) {
        for (j = 0; j < i - cnt; j++) {
            if ((sum[i] - sum[j]) % 7 == 0)    cnt = i - j;
        }
    }
    if (cnt == 0)  cout << "0";
    else cout << cnt;
    return 0;
}

想法(阶段三)

优化有成效,但还是不能过全部点,不是优化的问题,应该有时间复杂度更小的方法。看题解知道一条特性:若两个数相减 (mod 7 = 0),那么这两个数 mod 7 的余数一定相同。
我们只需要在求a数组时边求边模,求出每个余数各自最长的长度,最后排序取最大值即可

AC代码

#include <bits/stdc++.h>
#define int long long
#define endl '\n'
using namespace std;
int n, i, a[50005], cnt, j, l[7], r[7];
signed main() {
    ios::sync_with_stdio(0);
    cin.tie(0);
    cout.tie(0);
    cin >> n;
    for (i = 1; i <= n; i++) {
        cin >> a[i];
        a[i] = (a[i - 1] + a[i]) % 7;
    }
    for (i = n; i >= 1; i--)
        l[a[i]] = i;
    l[0] = 0;   //如果没有这句,当只有一个数字是7的倍数时,会输出0
    for (i = 1; i <= n; i++)
        r[a[i]] = i;
    for (i = 0; i <= 6; i++)
        cnt = max(r[i] - l[i], cnt);
    cout << cnt;
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Achilles0705.

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值