HDU - 2054 A == B ?

Description

Give you two numbers A and B, if A is equal to B, you should print "YES", or print "NO".

Input

each test case contains two numbers A and B.

Output

for each case, if A is equal to B, you should print "YES", or print "NO".

Sample Input

1 2
2 2
3 3
4 3

Sample Output

NO
YES
YES
NO

 【注】:这个题的关键是“找小数点”,把小数部分末尾的0去掉,再进行比较。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>

using namespace std;

char a[20000], b[20000];

void change(char s[])
{
    int len = strlen(s);
    if (strchr(s, '.') != NULL)
    {
        while (s[--len] == '0')
            ;
        if (s[len] == '.')
            len--;
        s[len+1] = '\0';
    }
}

int main()
{
    while (scanf("%s %s", a, b) != EOF)
    {
        change(a);
        change(b);
        if (strcmp(a, b) == 0)
            printf("YES\n");
        else
            printf("NO\n");
    }
    return 0;
}

 

  • 3
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

牧心.

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值