7-1 二分查找 (20分)

输入n值(1<=n<=1000)、n个非降序排列的整数以及要查找的数x,使用二分查找算法查找x,输出x所在的下标(0~n-1)及比较次数。若x不存在,输出-1和比较次数。
输入格式:

输入共三行: 第一行是n值; 第二行是n个整数; 第三行是x值。
输出格式:

输出x所在的下标(0~n-1)及比较次数。若x不存在,输出-1和比较次数。
输入样例:

4
1 2 3 4
1

输出样例:

0
2


```cpp
#include<cstdio>
#include<string>
#include<iostream>
#include<algorithm>
#include<cmath>
using namespace std;
int main(){
	int n;
	cin>>n;
	int a[n],m;
	for(int i=0;i<n;i++){
		cin>>a[i];
	}
	cin>>m;
	int f=0,l=n-1;
	int flag=0;
	while(true){
		flag++;
		int h=(f+l)/2;
		if(a[h]==m){
			cout<<h<<endl<<flag;
			return 0;
		}
		else if(a[h]>m){
			l=h-1;
		}
		else if(a[h]<m){
			f=h+1;
		}
		if(a[h+1]==m){
			cout<<h+1<<endl<<flag+1;
			return 0;
		}
		if(f>l){
			cout<<"-1"<<endl<<flag;
			return 0;
		}
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值