杭电1385(Floyd最短路+最小花费+输出路径)

Minimum Transport Cost(难度:1)

Time Limit: 2000/1000 MS (Java/Others)
Memory Limit: 65536/32768 K (Java/Others)

Problem Description

These are N cities in Spring country. Between each pair of cities there may be one transportation track or none. Now there is some cargo that should be delivered from one city to another. The transportation fee consists of two parts:

The cost of the transportation on the path between these cities, and

a certain tax which will be charged whenever any cargo passing through one city, except for the source and the destination cities.

You must write a program to find the route which has the minimum cost.

Input

First is N, number of cities. N = 0 indicates the end of input.

The data of path cost, city tax, source and destination cities are given in the input, which is of the form:

a11 a12 … a1N
a21 a22 … a2N
……………
aN1 aN2 … aNN
b1 b2 … bN

c d
e f

g h

where aij is the transport cost from city i to city j, aij = -1 indicates there is no direct path between city i and city j. bi represents the tax of passing through city i. And the cargo is to be delivered from city c to city d, city e to city f, …, and g = h = -1. You must output the sequence of cities passed by and the total cost which is of the form:

Output

From c to d :
Path: c–>c1–>……–>ck–>d
Total cost : ……
……

From e to f :
Path: e–>e1–>……….–>ek–>f
Total cost : ……

Note: if there are more minimal paths, output the lexically smallest one. Print a blank line after each test case.

Sample Input

5
0 3 22 -1 4
3 0 5 -1 -1
22 5 0 9 20
-1 -1 9 0 4
4 -1 20 4 0
5 17 8 3 1
1 3
3 5
2 4
-1 -1
0

Sample Output

From 1 to 3 :
Path: 1–>5–>4–>3
Total cost : 21

From 3 to 5 :
Path: 3–>4–>5
Total cost : 16

From 2 to 4 :
Path: 2–>1–>5–>4
Total cost : 17

思路:

在最短路径基础上,同时求最小权值,输出路径和权值。
Floyd求最短路径,增加对path数组最小值的判断。
(3790题是用dijkstra算法,本题无样例个数限制,采用Floyd算法)
(1224题是根据城市权值推出边权值,本题在有边权值的同时又有城市权值)

AC代码:

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
#define maxn 105
#define INF 0xfffffff

int n;//n个城市 
int cos[maxn][maxn];//cos[i][j]为i到j的花费 
int path[maxn][maxn];//记录路径 
int city[maxn];//城市的税 

void floyd()
{
    for(int k=1;k<=n;k++)
    {
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=n;j++)
            {
                if(cos[i][j]>cos[i][k]+cos[k][j]+city[k])
                {
                    cos[i][j]=cos[i][k]+cos[k][j]+city[k];
                    path[i][j]=path[i][k];
                }
                else if(cos[i][j]==cos[i][k]+cos[k][j]+city[k]&&path[i][j]>path[i][k])
                {
                    path[i][j]=path[i][k];
                }
            }
        }
    }
}

int main()
{
    int src,dest;//起始城市结束城市 
    while(cin>>n)
    {
        if(n==0) break;
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=n;j++)
            {
                path[i][j]=j;//初始化 
                cin>>cos[i][j];//输入花费(边权值) 
                if(cos[i][j]==-1) cos[i][j]=INF;//两个城市不连通 
            }
        }
        for(int i=1;i<=n;i++)
        {
            cin>>city[i];//输入城市权值 
        }       
        floyd();
        while(cin>>src>>dest)
        {
            if(src==-1&&dest==-1) break;
            printf("From %d to %d :\n",src,dest);
            printf("Path: %d",src);
            int i=src;
            while(i!=dest)
            {
                if(path[i][dest]==dest) cout<<"-->"<<dest;
                else cout<<"-->"<<path[i][dest];
                i=path[i][dest];
            }
            cout<<endl;
            cout<<"Total cost : "<<cos[src][dest]<<endl<<endl;
        }
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值